Rhino 6 Material Library - Material editor is pointing to an online bitmap image but the assigned objects are black

materials
unhandled

#1
  1. If I import an .rmtl material from the rhino 6 material library and assign it to an object the object is black.

  1. I’ve noticed that the bitmap texture is trying to reference a .jpg from an online url.

  2. The image file is at the website.
    http://files.na.mcneel.com/rhino/6.0/textures/Floor wood dark_1000_DF.jpg

  1. But, for some reason it doesn’t bring the bitmap image into the model.

Any thoughts as to a solution?


(Pascal Golay) #2

Hello - I’m checking this… @donner -what is the exact version that you are running? (Help>About Rhinoceros).
If you are running an SR1 release candidate, please see if there is an update available. (Options > Updates and Statistics)

-Pascal


(Nathan 'jesterKing' Letwory) #3

When assigning such an object from the material library in theory Rhino should start downloading the associated bitmap image from the server. For this to work your Rhino should be able to find and connect to the download location.

You can let Rhino download all bitmap textures from the server in one go in the Libraries panel. Click on the tripple-bar menu icon and choose Download all library textures.

If that doesn’t work either please report back. The output of the Rhino command _SystemInfo (or Help > System Information, which is the same) could be useful too. Attach it to a reply in this thread.

Thank you,

/Nathan


(Reis) #5

Hello Pascal,

I have the same problem. Textures that include ‘special’ bitmaps appear deep black. The problem appeared on my old iMac and I thought that it could be a problem with the virtual machine but then I took my new Lenovo Yoga 920 where die textures are black, too. I experimented a little bit and found out, that some bitmaps work fine but others not although I could not find any difference in the file formats. Thus, when creating a new user defined material with a color texture that appears black you can solve the problem checking the color mask bottom. Then it works but it is not the solution. When using plugins like Shapediver for Grasshopper which address the Rhino viewer there is no way for checking this mentioned box. Maybe it would work if the box is checked by default.

Here some screenshots:


This shows the problem in rendered view.


This shows the problem in shaded view with only the object being rendered.


Settings with unchecked box for color mask.


Settings with checked box for color mask.


Another material with another bitmap that works. Both are pngs with 24 bit. I also tried to convert the images with and without alpha cannel or into jpgs without any success.

I use the latest Rhino release candidate. Both textures are located on my dropbox. The problem also appeared when the bitmap is saved directly on the desktop.

I mentioned Shapediver… It is interesting, that shapediver is giving back also only black textures in Grasshopper respectively in the Rhino viewer but uploaded at Shapediver the textures appeared completely well.

Hoping for a solution.

Best Regards.
Martin


(Reis) #6

here are the original bitmaps:


This works.


This not.