Materials show up black

Hi,

I created a custom template file with several materials to load up as default when I open Rhino.
When opened the materials are black.

But, if I open the file in a normal way, materials do show up correctly-
So what’s wrong with the template?

Can you check if the material files are still linked?

Hello - that seems to work OK here - can you put the attached file in your Templates folder and open it using New, and see the texture?

materialtest.3dm (221.1 KB)

-Pascal

Hi @pascal.
I tested. Mine is also working using New.
It shows black when i use the file when rhino starts:
image

Hi Bogdan - I see - that works here; I do not know what might change with that setting but I’ll ask. Can you please run SystemInfo in Rhino and copy/paste the results? I am pretty sure the developer will want that information.

-Pascal

Ok, It’s hard to understand. Here’s system info:

Rhino 7 SR2 2021-1-12 (Rhino 7, 7.2.21012.11001, Git hash:master @ 2f08cf516ffc716c4c4a369abf7625798ef79bca)
License type: Evaluation, build 2021-01-12
License details: Stand-Alone
Expires on: 2021-04-14

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Radeon RX Vega M GL Graphics (AMD) Memory: 4GB, Driver date: 2-28-2020 (M-D-Y). OpenGL Ver: 4.6.13587 Compatibility Profile Context 20.2.2 26.20.15019.19000
> Accelerated graphics device with 8 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-25-2019 (M-D-Y).
> Integrated graphics device with 2 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 2-28-2020
Driver Version: 26.20.15019.19000
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\bogda\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.20335.757

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21012.11001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Bogdan - can you please block Enscape in Options > Plug-Ins page and then close and restart Rhino, does that make any difference?

-Pascal

I did, and restarted. Same situation.

It has something to do with “use this file when rhino starts”. if i open the file in a normal way the textures are there.

Yep, OK. I’ll investigate. I mean delegate, to the bigger brains.
@Bogdan_Chipara - if you render the planes, do they also show as missing the textures (full render)?

-Pascal

Nope, they show up.

Wait, now I am confused - under what circumstances do they show as black? Can you send me the file, saved with textures? Are these objects ‘Pictures’?

-Pascal

when SetObjectDisplayMode is set to rendered while SetDisplayMode is set to Shaded. only when “use this file when rhino starts”
Display modes are still a mess…

@pascal, wouldn’t it be better to do a session with teamviewer at some point ? where I can share screen and you can also take control. there are so many issues that i pointed out over the years… many still present in R7

I see - can you please send me the template file or send to tech@mcneel.com? Please include a link back to this topic in your comments.

-Pascal

@Bogdan_Chipara - I got your file - it works as expected here - I can’t, so far, make it not work - when the textures show black, does editing the texture show the expected path to the image file?

-Pascal

yes, Some show the custom paths, others are in AppData, and the texture is visible in the edit texture section. but in the viewport they are black. Only when the file is set to “use this file when rhino starts”.

Here^s a video: