Rhino 6 mac Beta

I don’t use any of these except Blueprint which I believe is based off one of them (?)…

but yeah, the test command does improve this mode… without the TechMode test, there’s a slight delay prior to accelerating the navigation (using a trackpad which has a sort of acceleration/deceleration thing)

after running the test command, this little lag goes away…

also, if I TestMaxSpeed, I get nearly double the frame rate with TestTechDisplayMode toggled on…

(36FPS vs 20)


sorry, that’s all I got for this particular test :wink:

Don’t be sorry, that is great. Also, yes blueprint would be affected by this change. I’m hoping to get this feature turned on by default in the initial service release, but there is a bug with blocks I need to fix first as well as another optimization that will speed up the drawing of the intersection curves.

@stevebaer TestToggleTechDisplayMode:

not as spectacular as Jeff, but better: old vs new:
technical, pen, pen outline with the file posted earlier. Still in these modes this feels very laggy.

Also when rotating the viewport with the trackpad, when I give it a swing, there is a hickup after I release the trackpad. While swiping it kind of ok and after release also, but in between it stalls for a short moment.

Command: testmaxspeed

Time to regen viewport 100 times = 10.20 seconds. (9.81 FPS)
Time to regen viewport 100 times = 6.24 seconds. (16.02 FPS)
Time to regen viewport 100 times = 6.66 seconds. (15.03 FPS)

Time to regen viewport 100 times = 7.87 seconds. (12.71 FPS)
Time to regen viewport 100 times = 4.46 seconds. (22.42 FPS)
Time to regen viewport 100 times = 5.51 seconds. (18.16 FPS)

Those are still heading in the right direction. Results are going be very different from model to model right now as I still need to implement intersection wire drawing a different way. If the model has a significant number of intersections to draw, you won’t notice a big difference in performance.

Thank you for looking into this, it really does make a difference! :slight_smile:
My models do run quite a bit smoother now on outline views:

Old:
Time to regen viewport 100 times = 5.65 seconds. (17.71 FPS)
New:
Time to regen viewport 100 times = 3.20 seconds. (31.26 FPS)

With shadows activated:

Old:
Time to regen viewport 100 times = 14.59 seconds. (6.85 FPS)
New:
Time to regen viewport 100 times = 12.17 seconds. (8.22 FPS)

I’m mostly using outline view modes for presentations, so smooth navigation in the perspective view is my main concern at the moment.

I would really like it if I could open mac v5 and v6 beta at the same time.

Like this I always have to close the other and it is difficult to test the new versions while still working in v5.

Hello,

I’ve updated to the latest beta (Version 6 WIP (6.16.19197.13284, 2019-07-16)), Rhino became unusable. Existing or new model, doesn’t matter, even if I create a simple box, beach balling between the clicks all the time.:frowning:

Navigating also, I haven’t had issues before with shaded/wireframe, now it’s a disaster also, panning and rotating/zooming is useless - lagging and beachballing with each move.

MBP 2015 15" with 2,5GHz i7, 16GB RAM, AMD Radeon R9 M370X 2 GB (+Intel Iris Pro 1536 MB), macOS 10.14.5

Suggestions?

Thanks!

Can you please provide steps for reproducing this behavior? 6.16.19197.13284 is behaving just fine here. I suspect your preferences have somehow gotten broken. You might try resetting them to see if that changes things. Make sure to save a backup copy in case it doesn’t change things.

hi @dan,

that’s the thing:

  1. open RhinoWIP
  2. do anything

I’ve tried resetting the preferences, no luck there.
I will reinstall RhinoWIP and see what happens.

Did you ever install any plugins? That may also be a potential cause of this behavior

do Grasshopper’s plugins count?

Yes.
The components are installed in:

~/Library/Application Support/McNeel/Rhinoceros/MacPlugins/Grasshopper/Libraries/

(aka /Users/<you>/Library/Application Support/McNeel/Rhinoceros/MacPlugins/Grasshopper/Libraries/ )

Your Library ( ~/Library/ ) is hidden by default, so you might need to use the Finder > Go To Folder… and copy/paste the first path above.

This is the folder that you get to from Grasshopper if you go to File > Special Folders > Components

Yes, they count. Most likely they are not the problem, but it is good to eliminate them as a possible cause

For any Windows user following along this Mac topic, RH-53792 - Technical Display Performance improvements is also available in the latest Service Release Candidate for SR17 on Windows too.

@OXII can you post some testmaxspeed results for the template model that you sent?

i try it …

Command: TextObjectestToggleTechDisplayMode
Unknown command: TextObjectestToggleTechDisplayMode
Command: testmaxspeed
Time to regen viewport 100 times = 87.73 seconds. (1.14 FPS)

Version 6 WIP (6.16.19197.13284, 2019-07-16)

In technical view.

33

Hi Peter-

The best testing procedure is as follows.

  1. Please post your_testing_model.3dm here so we know what you are testing with*
  2. Launch the RhinoBETA 6.16.19197.13284 and open your_testing_model.3dm.
  3. Run TestMaxSpeed and note down the result.
  4. Run TestToggleTechDisplayMode to enable Steve’s optimizations.
  5. Run TestMaxSpeed and note down the result.

I notice you are still running macOS High Sierra. Is there something that is preventing you from updating to macOS Mojave? If Apple has made improvements to OpenGL drivers, you would see them there.

*some models should see significant improvements in 6.16; other optimizations have been added to 6.17 that will be available in the first Service Release (update) for Rhino 6 for Mac.

@stevebaer, @jeff some great improvements!

6.21 rc:

shaded: Time to regen viewport 100 times = 1.27 seconds.
penoutline: Time to regen viewport 100 times = 2.56 seconds.
Technical: Time to regen viewport 100 times = 3.29 seconds.
Arctic (default: 25mb for shadows): Time to regen viewport 100 times = 82.48 seconds.
Arctic (grainy shadows, 1mb): Time to regen viewport 100 times = 16.72 seconds.

Apart from Arctic, which seems a bit slower, things seem to have vastly improved! But with Arctic I have the impression that the default quality is a bit higher than earlier versions, not sure.

and this seems to be solved as well mostly, just a very tiny hickup in technical. (in arctic rotating smoothly is no option on my system but that’s expected given the hardware)

3 Likes

Great to hear that. Thanks for letting us know.

I have basically the same specs and have no problems in any of the views except for “Ghosted” View recently when I uploaded a couple of larger blocks. But I understand your frustration. I’m currently trying to figure out why my “Ghosted” view lags so hard - but in wireframe its fine.

I’ll be on the lookout to see if you found any solutions!