Rhino 6 installation issues - English Language pack Failed - HELP!

Hi all.,

I have been using Rhino for years. I uninstalled recently because i was experiencing issues. I tried to reinstall and have been unable.

this is the message I am receiving:
Installation Failed with error code

en_lang_pack:-2147023293

The message says “The older version of Rhinoceros 6 Language Pack Installer (en-US) cannot be removed. Contact your technical support group.”

There is a log file that is generated after the installation failure.

Thank you

Stylianos

Old language pack