I can't find a way to install Rhino 6 10

installation

(Arnedoterrenas) #1

Hi, I am almost giving up.
I can’t find a way to get Rhino 6 to install.
I am getting that “the older version of Rhino 6 cannot be removed”
I tried everything I found in the web, nothing.
I manually removed everything related to “rhino” and “mcneel” from the registry and still nothing
I am attaching the log
Rhino_6_20181207202540.txt (268.1 KB)

PLEASE HELP!!!
Thank you!


(Brian Gillespie) #3

Hi,

I’m glad you asked instead of giving up!

This often happens when people use something like CCleaner to clean of “unnecessary” files from their computers. It can also happen with a system restore, or when upgrading from one version of Windows to another.

At any rate, the fix is to download and run Microsoft’s tool to Fix problems that block programs from being installed or removed.

Please download and run that, and then select from the list anything that looks related to Rhino 6 installation. There are several possibilities: the Rhino 6 language pack, the Rhino Installer Engine, and Rhino itself.

Once that has been cleaned up, Rhino should be able to install correctly.


(Arnedoterrenas) #4

Hi Brian, thank you for answering.
I used that tool, didn’t find anything related to rhino but did find 3 entries with no names. I could uninstall 2 of these the 3rd one failed.
After that I tried to install rhino again and now i get a message saying:
The feature you are truing to use is on a cdrom or other removable disk that is not available
inset the " disk

the browser is looking for the language pack, I couldn’t find it.
any ideas?
thanks


(John Brock) #5

Assuming you are running the Rhino V6 installer downloaded from the rhino Download page, then it’s possible you have an Antivirus tool getting in the way.
Please temporarily disable it and try running the Rhino installer again.

Any luck?


(Arnedoterrenas) #6

Hi,
No antivirus, just windows defender.
I managed to succeed with the off line installation, I did have to install it in spanish though somehow the english pack is missing.


(Arnedoterrenas) #7

I tried running the install again>modify>add language pack but en-us is missing


(John Brock) #8

Go into Rhino Options, Appearance. The top option is for Language. Is English there?


(Arnedoterrenas) #9

nop
As I mentioned, I even tried to use the installer but the installer cant find the language pack


(John Brock) #10

Bizarre

One other thing to try.
In Windows Control Panel > PRograms and Features > Rhino 6 > Modify
See if you can add English there.


(Arnedoterrenas) #11

same result.
It prompts me to the browser to try and find it manualy


(John Brock) #12

I’m out of ideas.
I agree with Brian. When you install software in Windows using the Windows Installer service, the installer is saved along with the list of file that were added and a link to the local cached installer on the computer.
Normally, when a tool is uninstalled, then the MSI tool uses that chashed information to remove any unmodified files it added based on the cached information.

These so-called “system cleaners”, if so configured, delete these cached installers and file lists. They can use up storage space over time.
My guess is one of these tools was used and it only partially succeeded.
Your on-going symptoms and the failure of Microsoft’s fixer referenced in Brian’s post are what make me think this.

I suppose if it were me, I’d try the MS fixer tool again and see if that corrects the problem. Next I would contact technical support for the cleaner tool that was used (assuming one was), for help, but I have very low hope for that.

The last option is to cut your time losses and have IT re-image your machine and start over. This has been Microsoft’s suggestion when this has happened in the past.

Sorry, that’s all I have.


(Arnedoterrenas) #13

John, I did use a few of those tools in the past so I guess is going to be hard to fix the mess they made.
Is there any En-Us english pack that I can download, just like the other packs?


(John Brock) #14

Since Rhino is written in US English, it’s supposed to always be there.

There’s not a separate installer I’m aware of.
I just ran the off-line install builder tool and US English is not on the list of additional languages.

Maybe @brian will have another idea when he comes back this afternoon.


(Arnedoterrenas) #15

Well good news!
this is how I manage to do it:
-I run the windows uninstaller repair again and found an entry with no name, went to the registry and deleted it
-Run the rhino installer repair
-restart’
-run the rhino installer>modify>added the english language
success!!!
Thanks you all for trying to help


(John Brock) #16

Outstanding!

Please, NEVER use one of those “system cleaner” tools again!

Cheers