Rhino 6 | Grasshopper - Arctic, Render or Raytraced mode display request

grasshopper
unhandled

(David Rutten) #21

Human components should behave like regular components, it will work. Custom Preview probably won’t be updated again for GH1.


#22

Thank you David! That would be great and already practical if external preview components like custom preview linewights and custom preview materials (with bitmap textures) from human would work as well in Arctic, Render or Raytraced as it was in Rhino 5.

As you really want to be able to use these components especially in junction with rendered display modes.
However in my actual build (Rhino Version 6 SR5 (6.5.18143.7081, 05/23/2018)) the don’t work in this modes so I’m a little confused if this change already took place or not…


(Nathan 'jesterKing' Letwory) #23

Arctic and Raytraced didn’t exist in V5…


#24

Busted! But it worked in rendered…


(David Rutten) #25

It should, assuming they just use the regular preview mechanism.


#26

What is

?

So the changes you described in that post are not present yet in the latest public built ( SR5 (6.5.18143.7081, 05/23/2018))? Sorry I’m confused about that now.


(David Rutten) #27

Sorry, bit of internal jargon there. Any work on Rhino6 happens in code labelled 6.x. Then every month or so we make a copy of the current 6.x and call it 6.1, 6.2, 6.3, etc. We no longer make changes to this copy, except if people find bugs which are then fixed.

I made my changes in 6.x, meaning they’ll get included whenever the next Rhino6 service release is copied. It may be 6.5, maybe 6.6.

If you want to know whether a specific issue has been fixed and is available in your current Rhino installation, you can use the _GetIssueState command. Of course you’ll need to know the issue id, which in this case is RH-45046. The feedback from that command is pretty geeky too, but if included=true, that means the version you currently have contains the new code.

You can also view the issue online, by using the same id with the url: https://mcneel.myjetbrains.com/youtrack/issue/RH-45046


(IVELIN PEYCHEV) #28

Thanks David, this is very helpful.


#29

Thanks for the info! The changes are carried over to the current public release now. Everything is working great! Awesome!


#30

@DavidRutten It seems there is some buggy behaviour if a slightly modified version of the Arctic Display Mode is used.

  1. Create a copy of Arctic - I named mine “Arctic HeavyLines GH”
  2. Surface Edge Settings->Set Edge thickness (pixels) to 3 pixels
  3. Objects->Surfaces->Change Edge color usage to “Use single color”

Now try using custom preview and switching between Arctic, Arctic HeavyLines GH, and Shaded. Geometry rendered by GH gets “stuck” in the render pipeline, and even if geometry preview is disabled, the geometry remains previewed.

Preview in Shaded mode, with GH preview disabled - box is hidden as it should be:

Preview in Arctic or Arctic HeavyLines GH, with GH preview disabled - the box still shows up:

Would be great to get this working, as it’s really useful to use Arctic with more emphasis on the edge curves.