Grasshopper Display Messed-up

unhandled

(Lei Yang) #1

Hello guys,

I recently encounted a problem that the parametric display in rhino viewport got messed-up.
here is the picture shows the problem.
any ideas?

Best,
Lei


(Michael Pryor) #2

Do you have bump preview on?


(Lei Yang) #3

Hi Michael,

Thanks for the reply.
but what is ‘bump preview’ you mentioned?


(Lei Yang) #4

Found the ‘bump preview’. clicked off and on but the viewport remains messed-up :frowning:


(Wim Dekeyser) #5

Is this perhaps far from the origin? And Rhino 5 or 6?


(Lei Yang) #6

hi wim,

I had rhino5&6 both installed.
wil that be the issue?


(Lei Yang) #7

I just uninstalled rhino6, didn`t work.


No grasshopper preview in rendered mode (viewport style)
(Wim Dekeyser) #8

If anything, it should work better in RH6.
Can you post the internalized results from your definition in a reduced gh file?


(Lei Yang) #9

Here it is.
Thanks.


2.gh (58.0 KB)


#10

Yes. This is a typical point in the model. {3.8383e+7, 3.8443e+6, 33.3}

I don’t follow the logic of subtracting one point from another and treating the result as a vector (or I wouldn’t do it that way), but the model basically looks OK in R6. Except for ‘Rendered’, ‘Arctic’ and ‘Raytraced’ modes which all show blank screens. :frowning:


(Lei Yang) #11

Thanks Oster and Wim,

It`s the problem far from origin point.
Thank you all for the help!

Best
Lei


(Michael Pryor) #12

Except for ‘Rendered’, ‘Arctic’ and ‘Raytraced’ modes which all show blank screens.

This is because now the custom preview component has a material input instead of a shader input. You set materials there and they will actually render as those materials as a gh preview when on those display modes.


(Nathan 'jesterKing' Letwory) #13

Note that these materials can be document materials as well.


(Lei Yang) #14

COOL, this is nice.


(Laurent Delrieu) #15

Putting a name of material as input works. But the shininess still doesn’t work for me. Am I the.only one using this ?


#17

Thanks Michael. I just don’t understand the lack of concern at McNeel for compatibility (and usability!). One of the greatest features of R6 is the dazzling ‘Rendered’ mode but all my old GH models are useless in this mode unless I painstakingly replace all the Custom Preview color inputs with materials - even contours!? Not only is that inconvenient, it makes the modified files incompatible with R5? That’s really uncalled for and rather rude. Why can’t color values in old GH models be treated as the old “default material”? The geeky justifications from McNeel for making life difficult for users is quickly wearing thin.


#18

FYI, you should add custom preview to your R5 GH files that do not use it from the beginning,
but there’s no problem seeing your geometries in R6 Arctic or Render mode without replacing the original Custom Preview’s shader input with material…


#19

I don’t understand this? Please clarify? In R5, I’ve used Custom Preview the only way I know how. I get the same result with my own models as I did with @Lei_Yang1’s model in this thread. No GH preview geometry visible in those three rendering modes.


#20

As @Michael_Pryor said, if you don’t have Custom Preview in your old file, then you have to add it inevitably to see it in R6 Render mode.
But if the old files had a Custom Preview with shader input from the first place, you don’t have to replace it to the material input.


#21

That doesn’t quite match my experience @HS_Kim. My old GH files do have Custom Preview components. Ghosted preview looks like this:

Rendered preview looks like this - missing curves, contours and curvature graphs (and what happened to the blue window frames?). Enable/Disable Preview on Custom Preview components has no effect, the components themselves must be disabled. No matter what the technical reasons are for this behavior, it is a disruption of prior practice - an unpleasant surprise,

By the way, while these images don’t show it, I have a Rhino model that contains additional geometry (hulls, interior accommodation details) that look great in Rendered mode but I can’t show my full GH model with those Rhino parts rendered.