Rhino 6 extend line

Hi there,
seems to me the extend-line command is not working.
I mean at the moment its not possible to extend the line with a loose curve.
(sorry, i don’t know what is the english name of this command, pls look at the screenshot)
All i get is a straight line… is this only my experience?
Regards, Christopher

Use Type=Natural or Type=Smooth

After selecting the curve, use the ToPoint option to pick the location of the end of the extension.

The ToPoint option in Extend is new in V6. Selecting it provides the same behavior as Extend in V5.

Ok, thanks this works. I still don’t understand why you have this option as there is already a command for the straight line…

This command is behaving differently in V6 compared to V5 - with the same macro. I also prefer the way it works in V5.