Rhino 6 :disabeling sub object selection for curves

unhandled

#1

Hi is there any way to disable sub object selection for curves?

meaning that I do not get asked all the time about the curve segment when I try to pick a grouped curve…

disabling the sub objects in the selection filter turns off group selection too… is this on purpose?
does not really make sense to me. I think group selection should remain, and ctrl+shift still selects whole objects in a group, but no segments.

thanks,
Daniel


(Pascal Golay) #2

Hi Daniel - There isn’t that I can think of but this rings a bell, albeit faintly… It seems to me something was changed in this area or close enough that it’s confusing me. I’ll check with the developer, I might be way off base.

Aha, I remembered, a minor miracle in itself:
testToggleSubObjectSelect

Try that…

-Pascal


#3

That will however suppress all sub-object selection, not just curves, n’est pas…?


(Pascal Golay) #4

Hi Mitch - within groups, I think, yes.

-Pascal


#5

Hi Pascal,
Nope, here it completely disables it, groups or not…
–Mitch


(Pascal Golay) #6

Yeah, you’re right - I don’t know if this can be micro tuned. I’ll ask Mikko.

-Pascal


#7

I understand @dk2079’s problem, I ran into this the other day. Every time you attempt to ctrl+shift select an curve in a group, you get the multi-select dialog with the curve plus the sub-curve you clicked on.

It seems like the parent object (curve) is always first on the list. Didn’t someone come up with an option to suppress the multi-selection box and always pick the first item? Of course that would also be global I guess, so we’re back to square one…

–Mitch


#8

Yes Mitch,
that is exactly it, I do A LOT of grouping when I have to draft quickly… make 2ds… contours, hatching… etc, and I am pretty much never interested in sub selecting a curve segment, so it is visually straining to select trough the pop up entries, especially when picking obects that are lying ontop of each other.

What about splitting these? I mean in the filter: subGroups and subObject?

cheers,
Daniel


(Pascal Golay) #9

Hi Daniel - it sounds like maybe the toggle I pointed out will work for you as is, for the most part, is that correct? You don’t need sub-object selection in general for some period of time when you’re working as you describe? In any case, I asked the developer if there could be a more fine-grained setting.

thanks,
-Pascal


#10

In the SelectionFilter, there is now a checkbox for toggling sub-object selection on and off globally. So actually there isn’t really a need for the test command anymore I guess…


(Pascal Golay) #11

Hi Mitch - The selection filter setting seems a little different again, if my coffee is doing its job - it toggles the Ctrl-Shift and normal click behavior.

-Pascal


#12

Dunno, maybe my wine is doing its job here… :stuck_out_tongue_winking_eye: But clicking the checkbox in the SelectionFilter panel seems to eliminate Ctrl+Shift sub-object selection entirely, like the test command… i.e. I can no longer select sub-objects at all…


#13

that is interesting, it looks like this test command works with coffee, and beer (Corona here, to be precise), but not with wine. I wonder how the developer implemented that!

thanks pascal, testToggleSubObjectSelect does exactly what I was looking for

@Mitch, sub objects need to stay on in the filter tollbar


#14

I still don’t see the difference…

With TestToggleSubObjectSelect on, but with the SubObject filter unchecked in the panel, I cannot Ctrl+Shift select any subobject, such as a single surface in a polysurface. As a matter of fact, even if the setting is checked in the filter panel, if TestToggleSubObjectSelect is on, it’s inactive (grayed out).

Wait a minute, something is messed up here - having played around with this, I see my Rhino got “stuck” in a permanent no sub object select no matter what the setting. Seems a bit buggy to me. Restarting…


#15

you are correct about what you are describing,
but what does work for me here is, after having used the testToggleSubObjectSelect command,
is using crtl+shift to select an object within a group, but keep normal group selection active.

however i am also a bit confused:

when I DISABLE sub objects via filter, the ctrl+shift behavior is inverted for groups.

ctrl+shift selects the group and normal selection disregards any groups.

what is strange is that sub oject selection remains turned on… and now anything I click (without crtl+shift) offers me to select edges,srfs,etc…

image