Rhino 6 crashing


#1

Rhino 6 wip is crashing when using the display setting “Rendered” I get a TDR (error code 7). This seems to happen repeatedly. The error seems to have something to do with NVidia GL drivers.


(Brian James) #2

Thanks for the report… can you run the SystemInfo command and paste what it reports back here? Also, does it happen with any model or just some?


#3

OS Name Microsoft Windows 10 Pro
Version 10.0.15063 Build 15063
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DAVID-PC
System Manufacturer Dell Inc.
System Model Precision M4800
System Type x64-based PC
System SKU 05CC
Processor Intel® Core™ i7-4800MQ CPU @ 2.70GHz, 2701 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date Dell Inc. A19, 5/14/2017
SMBIOS Version 2.7
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer Dell Inc.
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Mobile
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = "10.0.15063.502"
User Name David-PC\David
Time Zone Eastern Daylight Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 10.3 GB
Total Virtual Memory 31.9 GB
Available Virtual Memory 25.7 GB
Page File Space 16.0 GB
Page File C:\pagefile.sys
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

I hope this is what you were referring to: So far, it happens to a box I built with filleted edges and an offset surface, basically making a hollow box with an inner surface (offset surf with solid=yes)

r

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


(Nathan 'jesterKing' Letwory) #4

Please also run the SystemInfo command in the command-line of Rhino. You can access.it also through the Help menu.


(Brian James) #5

Thanks David, this helps but as Nathan mentioned please also type the command SystemInfo in Rhino and send back what that reports. It’ll have the graphics card info which I think we’ll need for this one.


#6

Here is the system info from Rhino 6

Rhino 6 SR0 2017-8-29 (Rhino WIP, 6.0.17241.13071, Git hash:master @ 4ba507bbd3a2d10cc10aa64a48c6283abe2fd544)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Quadro K1100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.16)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-9-2017
Driver Version: 22.21.13.8216
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp "Commands"
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp "Renderer Development Kit"
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp "Rhino Render"
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp "RDK_EtoUI"
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp "Renderer Development Kit UI"
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp "Snapshots"
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp "Cycles for Rhino"
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp "RhinoCycles"
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp "Toolbars"
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse"
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


(Brian James) #7

Thanks David, please type the Options command in the Rhino WIP and go to View>OpenGL, try unchecking “GPU Tessellation” to see if there is any change.

@stevebaer @jeff


(Jeff Lasor) #8

Have you been using the WIPs in the past without issue? Or is this the first time you’ve installed and run the V6 WIP?

Thanks,
-Jeff


#9

Jeff, It’s not the first time I’ve used Rhino 6 wip, but this is the first time I’ve had any issues. I tried the WIP on my home computer and had no problems, but it is Win 7 64 bit and my work computer is Win 10

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


#10

I will try that when I get back to work. On my home computer the same scene works with no issues but my home computer is Windows 7 and my work laptop is Windows 10, not sure if that makes any difference.

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


(Jeff Lasor) #11

Ok thanks… I’m just trying to see if we can isolate when it started crashing on your work computer… Because if it used to work on that computer and now doesn’t, figuring out the “when” would be huge in locating the cause.

Is Rhino creating a crash report? Or is it a hard crash and dumping you to the desktop?

Thanks,
-Jeff


#12

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com

I got a TDR error code 7 popup, then a notice the Rhino had stopped working. I don’t think a crash report was sent, at least I didn’t see any notice that one was being generated. I actually hadn’t used the WIP for sometime and when I tried it had expired and I downloaded the current build (as of 8-31-17) and I was playing with the software, not really testing features systematically, just using features I would normally use in Rhino 5.


#13

Unchecking GPU Tessellation did not help, also, no crash report is being generated, at least none that requires my input.

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


(David Eränen) #14

@airpainter,

Have you ever tried the command TestShaderCache? If you have, make sure the shader cache is disabled. You can toggle it with the command TestShaderCache.

Edit: After Rhino says it’s disabled, restart Rhino and try again.

-David


#15

I tried the TestShaderCache command and it was disabled by default. Still had the crash. The error message seems to have something to do with a Microsoft Timeout setting (TDR). I’m going to try the display setting with a simple object and see if Rhino still crashes.

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


#16

I tried a simple cube and the Rendered view setting and Rhino crashed with the same error message.

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


(Steve Baer) #17

Hey David,
I highly doubt the test commands that have been mentioned on this thread are going to help diagnosing the problem at all. Disabling the tessellation shader option really only affects wire drawing and there aren’t any wires being drawn in rendered mode. TestShaderCache just forces our OpenGL shaders to be reloaded every time Rhino starts instead of just reusing what was generated the last time Rhino ran.

If you are just drawing a box and Rhino is crashing in rendered mode, this is most likely a problem with your display driver that we need to diagnose and figure out how to work around. That and the fact that you are getting a TDR error means that something bad is happening in the display driver and Windows is attempting to “reboot” the driver.

Let’s try turning off some features of rendered mode to see if we can pin down where the problem is occurring.

  • On the rendering tab, uncheck the “skylight” option
  • In the advanced display settings for rendered mode, uncheck “Shadows on” in the shadows section.

With these features turned off, does rendered mode still crash? If it doesn’t, try turning one of the features back on to try and isolate exactly where things are going wrong. Please let us know the results so we can try and figure out what to do next.

Thanks,
Steve


#18

Steve,

Skylight was unchecked, turned off shadows and I don’t get a crash. Turned shadows back on and still no crash. I’ve restarted Rhino and reloaded the same object, still no crash. When I first turned shadows off Rendered mode worked fine, now it doesn’t crash and I’ve rest all of the settings I originally had and still no crash. It’s a good thing I get no crash, but it makes diagnosing the problem harder to isolate. I will try other, more complex objects, and see it the problem returns.

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


#19

Steve,

Skylight was unchecked, turned off shadows and I don’t get a crash. Turned shadows back on and still no crash. I’ve restarted Rhino and reloaded the same object, still no crash. When I first turned shadows off Rendered mode worked fine, now it doesn’t crash and I’ve rest all of the settings I originally had and still no crash. It’s a good thing I get no crash, but it makes diagnosing

David Goerndt

Cinnabar Florida, Inc.

407-649-7633

david.goerndt@cinnabarfl.com


(Steve Baer) #20

Well that was definitely not an expected result. I wish this were fixed, but I’m sure there is a good chance that this bug will rear its ugly head again. Let us know when that happens.