Rhino 6 bug - ShowEdges command does not work in Rendered display mode


#1

I used the FillMeshHole command to fill the hole on the front side of this pipe-shaped mesh.

mesh before FillMeshHole command: fill mesh hole bug1.3dm (392.6 KB)

mesh after FillMeshHole command: fill mesh hole bug 2.3dm (253.7 KB)


#2

The problem is your mesh, not the command. Turn on edge display>naked edges and you will see the mesh edges that have problems, especially the seam and the outer edges on the non planar hole side. Use MatchMeshEdge to fix the seam and the edges, then FillMeshHole and RebuildMeshNormals…

fill mesh hole no bug.3dm (179.0 KB)


#3

You are right - there was naked edge shown in the Shaded display mode (following screenshot):

I could not find the naked edge because I was running the ShowEdges command in Rendered display mode. This seems to be display bug - the Rendered display mode does not display mesh edges. No matter how wide the edges are set by the Options command, the thickness of all mesh edges is zero.

I believe that the Edge Analysis window should have an option for the width of the edges. As of now there are two awkward ways to display wide edges: Options command and Testwirethicknessscale.


#4

Yes, I saw that too when I looked at your file… This only appears to affect meshes; surfaces seem to work correctly in rendered mode. I didn’t see a bugtrack item for this one, so I created one.

https://mcneel.myjetbrains.com/youtrack/issue/RH-43967


#5

All I see is: “You have no permissions to view this page”


#6

Yeah, sorry, Youtrack is positively crappy in that respect, I tried to change the permissions 3 times already. I really don’t know what the heck is the matter with that thing but it hasn’t worked correctly in years.



(Steve Baer) #7

Click the visible to drop-down in the upper right area of the screen and uncheck specific members/groups to make the issue visible to all. The item that you are changing in the first image is for applying visibility to a new comment. The public view toggle is probably something should happen hide from people outside McNeel. This is used as a lock to make it difficult to accidentally make something publicly visible when the author of the issue really wants to keep it private.


#8

OK, that’s really logical… :upside_down_face:


(Steve Baer) #9

It confused a lot of people at McNeel too when the interface for this changed recently.


#10

@Andrew_Nowicki I changed this as Steve suggested, I hope it’s visible now.


(Steve Baer) #11

Thanks for creating the YT issue Mitch. For extra bonus points, if you add a link back to this discourse thread in the post the thread will get a notification when the issue is fixed in a public build.


#12

Ah, OK, those messages from Brian “XXX has been fixed in the current build” are all generated automatically by the system then? Didn’t realize that, thanks!


#13

Yes. It is visible now.


(Brian Gillespie) #14

RH-43967 is fixed in the latest Service Release Candidate


#15

This bug has been fixed in Rhino 6.3. It would be easier to see the naked edges if we could make them wider than other edges.