Rhino 6: Background bitmap is rotated 90 degrees vs JPEG

When I try to add a background bitmap to model over, it rotates the image 90 degrees clockwise but keeps the original nonrotated x:y aspect ratio, so the result is a distorted sideways image.

The workaround I’m using is to crop the image to a square aspect ratio and rotate it 90 degrees counter-clockwise, but I would prefer if I didn’t need to use a workaround. This has happened with a few different images that I’ve tried, so it wasn’t any kind of copyright/security feature somehow coded into the image (if that’s possible). I hadn’t used a background bitmap in quite a while, but had used them previously with no problems.

Any suggestions?

use the picture command, not background bitmap… that command is obsolete and has a lot of limitations. Picture, you simply rotate and move with gumball.

1 Like

Ok, got it. Played around with that a bit and figured out how to align and scale to some reference curves, and then lock it so it doesn’t always show up as a selectable item when I try to grab curves.

Doesn’t solve the original problem, but thanks for a second workaround!

That’s odd - can you post the image in question?

I really wish you guys would stop using that official dismissal mantra. The fact is that while you call it “obsolete” and the fact that yes, it does have limitations, Picture still is not capable of fully replacing BackgroundBitmap.

For the simple reason that a Background Bitmap is visible in one specific viewport, whereas a Picture object is visible in all viewports and you cannot selectively hide it in a particular view. It’s either visible in all views or not visible at all. Background bitmaps also have the advantage that they cannot be accidentally snapped to, which is not possible with a Picture object unless you disable SnapToLocked - which many people leave on because it is useful for snapping other things.

So until Picture can do all the things that BackgroundBitmap can, stop calling it obsolete and maybe even put some effort into fixing it so that it works better.


It happens with any image I use. I’ve tried with a couple of cropped ortho views of a product, and a found image of the front of a vehicle. The image doesn’t seem to be at fault.

Small update: The original image was being used in the Front viewport. I’ve now tried using the same image in Top and Right viewports and they work fine, but Front still rotates and distorts. I think we can agree this is not due to a limitation of the Background Bitmap function of the program.

Hi Joel - is your file using default views and CPlanes? If you run 4View twice, and then try BackgroundBitmap in Front, does it behave any better?


Hi Pascal,
I tried removing the background bitmap, then did 4View twice, and then placed the background bitmap again with the same rotated/distorted result.

I was using Universal CPlanes, but I haven’t reset any of them. Tried changing to Standard CPlanes in options, then did 4View twice, then placed the background bitmap again with the same rotated/distorted result.

OK - thanks for testing - can you run SystemInfo in Rhino and Copy/paste the results here? Can you also take a screen shot of the viewport (ViewCaptureToClipboard/File)


Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Commercial, build 2021-02-03
License details: Stand-Alone

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: HP

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 620 (Intel) Memory: 1GB, Driver date: 10-17-2017 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
NVIDIA GeForce 940MX (NVidia) Memory: 2GB, Driver date: 3-25-2021 (M-D-Y).
> Integrated acclerated graphics device (shares primary device ports)
- This device is not being used

No graphics device is being used. Either an error occurred on startup, or certain devices have been disabled.
See below for any possible configuration changes that may help resolve this issue.

  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: Off
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi @Joel_Ness,

If possible, please post the original .jpg file.


– Dale

Something is definitely borked with your graphics drivers.


I would try re-installing your graphics drivers and also look for an updated Intel driver.

Here’s a link to updated Intel drivers from 3 March:

Also, follow these instructions:

Same issue reported by a user using Rhino 6 for Windows in Parallel on Mac. (No solution found)