Rhino 6 asks for license key after using Rhino 7 WIP

just installed latest WIP, (7.0.19260.11525, 17/09/2019)
Rhino Version 6 SR18 (6.18.19253.10261, 10/09/2019)

Rhino 6 always ask for license key after using Rhino 7 WIP, is there any way to fix that?


just installed latest WIP, (7.0.19267.14135, 24/09/2019)
Rhino Version 6 SR19 (6.19.19267.15571, 24/09/2019)

license key problem problem still happen

1 Like

I have the same problem.

1 Like

Latest WIP installs and runs for me without requesting Rhino 6 license key. I’m using the Cloud Zoo.

Both installers worked fine here, it’s not an install problem.
No key where request while install.
My Rhino 6 Key is installed on my PC since 1 year.
After last WIP update Rhino 6 is asking for the key every time after using Rhino WIP.
That means that i have to re-enter the key quite often.

1 Like

@enzo_molinari, @samuelef1992
@brian A search found this post:

I submitted 3 error reports on repeated license validation problem yesterday, Sept. 25, Re: version 6.19.19267.15571. It is the same as Enzo described. Using Rhino 7 WIP messes with the License process in Version 6 SR19 (6.19.19267.15571, 24/09/2019). Emphasis on USING Just installing or reinstalling WIP doesn’t do it

I removed/uninstalled the WIP. The task manager still showed a Rhino 6 running.

Rebooted and then opened 6.19.19267.15571. Got the License message:
Entered license and it validated (stand alone.) To double check, I repeated the procedure; installed WIP, used it, opened SR19, same problem, removed WIP, rebooted, License messge reappeared, had to do a Repair on SR19, then it re-validated ok. Bottom line is without this WIP, 6 works as expected. Hope the many details will help.

Hi @Fred_C I see a lot of activity on your license for sure…

And I don’t really understand what’s going on. Can you please try this:

  1. Restart your computer
  2. Start Rhino 6 - does it ask for validation? If so, do it.
  3. Close Rhino 6
  4. Start Rhino WIP - does it ask for validation? If so, do it.
  5. Close Rhino WIP
  6. Start Rhino 6 - does it ask for validation?

Please let me know what you discover.

I can reproduce this problem:


:white_check_mark: :ok_hand: ThankYou

1 Like

Ran into this last night when I tried to update to the 9/24 releases of v6.19 and WIP. Through a PM Brian assures me (us) that tomorrow’s updates will fix this.

Sometimes I feel like the folks in this car:

1 Like

No pain, no gain!!!

hi @brian, today’s WIP solved the problem

thank you