Rhino 6.0, Bongo 2.0 , Render Animation, Target Render=Viewport, Can't get transparent frames

rhino-6

#1

I am trying to capture a view port animation with bongo in rhino 6. As usual I:

1.) Capture a single frame with transparency via view port capture.
2.) Check frame transparency and all is good.
3.) Render out animation and get no transparency.
4.) I also set transparency for backdrop and view port. View port transparency yields black bg in all frames

I am lost. Am guessing there is a setting I am not seeing. Any ideas?


Animation with transparent background
(IVELIN PEYCHEV) #2

You’ve shown these in windows explorer preview, try doing so in image editor like Paintdotnet or gimp2


(Luc Adriaenssen) #3

Rhino’s help
https://docs.mcneel.com/rhino/6/help/en-us/index.htm#options/view_displaymode_options.htm?Highlight=transparent
image
means that trancparency only occurs in a Rhino-rendered image (when transparent background is checked in the render options) or in a ViewCaptureToFile. The Bongo Animation Render uses the Viewport render - so hence no transparency.

Naturally I understand one would expect to get a transparent background under these circumstances. I’ll pass it on to the developers - see what they can do. Meanwhile you’ll have to stick to Rhino Render Target Output in order to get a transparent background.

Luc


#4

Understood. Rhino 5 keeps the setting from view capture to file. Then, subsequent view captures through bongo render view port capture with transparency without issue. I assumed this is because the bongo capture to view port just uses the view capture to file command in succession.


#5

Have you confirmed the problem isn’t just how they look in file explorer? It’s not good with transparencies.


#6

Yes Jim. Thanks for the suggestion. I use thousands of these frames for various media and animation. It was a rude surprise to see a behavior change in Rhino 6. I get black bg frames with viewport transparency turned on. Or viewport bg color with transparency turned off. And viewcapturetofile settings do not carry over to bongo export as they used to. Am guessing I could figure out a script as a work around. For 1 - number of ticks on time line advance time line one tick and viewcapturetofile? But I am not much of a programmer.


(Nathan 'jesterKing' Letwory) #7

ViewCaptureToFile should work also with Transparency turned on for the viewport, since that is what Bongo also uses. If it doesn’t do that properly it is a bug.


#8

I don’t think it is working correctly. I will better document after this project is done.


(Luc Adriaenssen) #9

Apparently I never tried to render an animation in one of Rhino’s views with a transparent background. Because then I would have known it worked well in Rhino 5. So yes @Nathan it’s a bug in the relation between Bongo and Rhino 6. I’ll make an entry in the bug tracker.

Migilbride, if you still have Rhino 5 running, you can transfer your model and do the animation render in Rhino 5.


#10

Thanks. That’s what I did.


#11

How big of a fix do you guys think this is? I’m working on a video clip that I would like Alpha background. I’m using Rhino 6 and the new ambient occlusion rendering style in the viewport, so going back to Rhino 5 is not a good option for me. Is this a Rhino update or Bongo update?


#12

sorry to double post, but I did find a fix, maybe it will work for you guys. Go to the Display Options of the viewport display mode (I’m using a custom mode I call Arctic Render). There in the First layer of options is Viewport Settings > Background. You can set it to Transparent, then all your Bongo output images will have a transparent background.


(Luc Adriaenssen) #13

Indeed one can do all of this but … on my system Bongo’s output images do NOT have a transparent background but rather a black one.
Did you test?

Luc


#14

Ah, yes I am having this problem too. dang


(Luc Adriaenssen) #15

The developers are currently going through a stack of bugs to fix.
The transparency issue (https://mcneel.myjetbrains.com/youtrack/issue/BO-2933) will certainly pass by.

Luc