Rhino 5 - Rendered View - no Shadows

In rhino 5 - rendered view, I can’t see shadows… at a different computer I was working at I had these dynamic shadows in rendered view, simultaneouly updating. I am missing that on this computer.

Windows 7 professional - 64 bit
Grafic card is: NVidia Quadro FX 3800
I’m using rhino 5 edu/ standard rhino render.

I updated to the newest driver version,but it has not changed anything.
I read the topics similar to my problem, but it did not help, that is why I am creating a new Topic.

hopefully there is someone out there helping me out.

I tried this: I deleted the rendered view from the display modes and restarted rhino. Then I created a simple plane with 4 boxes. Before deleting the rendered view it did not show shadows, after deleting it now shows the shadows. But only in this simple file. In my working file, which is has a file size of about 10 mb it still does not show the shadows.
I upload 2 sreenshots.
I copied the geometry from the “bad file” into the “good file”, but there still it doesnt work. Probably not a problem with the file.

I created this file from I Autocad 3D File I received. I realized that the geometry is far away from 0,0,0 therefore I moved all geomtetry close to 0,0,0 now I can see shadows in rendered view, but they are not as good as in the simple test drawing. What else could be a problem? The geometry I took from the autocad file is mainly meshes. could that be a problem? I reduced the geometry in the file, removed all curves, but still have not the clear sharp shadows as in the test file

hi elabela,

you might next try to adjust your shadow settings, located in the dialog below:


Hi Clement,

I tried and it improves the quality of the shadows. Many thanks.

Just one questions: why did I not had to adjust these settings in the test file with less and simple geometry? Do you know by any chance why?

phew, I am happy it works now… Was already worried, that a have a problem with the graphic card and already contacted dell customers support… can cancel that now :smile:


probably because of the size of the model. If your model is very large depending on the unit system used, the default shadow settings may need some tweaking.


the model is in meters…the “model-size” is approximately 500x500 meters
filesize is apprx. 12 mb

so is it because of the model-size not the file size?

thanks for the help

There are several factors which can influence the appearance of realtime shadows and even geometry. The modelsize and filesize you´ve listed above should not be a problem if your display card is powerful enough. Your simpler example was maybe drawn close to the origin which is optimal. You can check your larger model and try to improve the display if you move it closer to the origin in case it is very far away from it.

Also take care of the “Camera Based Clipping Bubble” slider. Your model should fit in that bubble. Do not adjust it unnecessary larger than your model. If the shadow settings do not get you better results, it might help if you upload your model so it can be further inspected.


Hey, in my Rhino 5,0 64bit I have exactly the same problem and none of these solutions are working for me.
Furthermore Rhino 6.0 is also not working (Link) and cannot install Vray at all.
Is it a hardware problem, that is not possible to be solved?

Rhino system info:

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 7 SP1 (Physical RAM: 7.8Gb)

Intel® HD Graphics (OpenGL ver:2.1.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 2.1
Shading Language: 1.20 - Intel Build
Driver Date: 1-30-2013
Driver Version:
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 3860312 KB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”

You did get this answer in that other thread:

Rhino 6 SR2 2018-3-6
Driver Date: 1-30-2013

We’re getting closer to SR10 by now but as long as there aren’t more recent GPU drivers, I don’t think that will make a difference.

As for your Rhino 5, which SR do you have installed for that version?