Zebra isn't smooth

Hi Kyle, I am having the exact same issue as Paul, except working in Rhino 6 Windows. Do you know what the comparable fix would be in Windows?

Can you please post a screenshot showing the problem and the model you’re using?

Zebra window has ‘Adjust Mesh’ button. Use it to increase zebra mesh density. If it does not help, increase render mesh density. The render mesh density is controlled by the Options command (Document Properties>Mesh).

Hi John, I may have spoken to you by phone earlier today? I get a beautiful result with zebra in wireframe ghosted and rendered, but in shaded it is jagged.
image image image image signet ring (3rd time) 006.3dm (675.5 KB)

Hi Andrew, thanks for your suggestions. They didn’t work :confused:

“Hey Paul, in your preferences, try resetting your rendered mode to defaults…any luck?”

This was the solution in the prior thread for Paul, who seemed to have the identical issue. Is there a similar reset option in windows?

My guess is the “Flat shading” option in the middle of that Options page is checked in the working display mode you’re using.

John, clicking on Restore Defaults fixed it!! Thank you :)))

Also I double checked - Flat shading was not checked. Problem solved!!


Which defaults are restored when I click the restore defaults? All defaults? All display mode defaults? Shaded display mode defaults?

If you’re asking about the Restore Defaults button on the Shaded Options page I showed above, then it resets the Shaded display mode settings.

I pretty sure @kate1 had the Flat shade option turned on.

I just saw this one yesterday


John - I was continuing on with my training videos and figured out exactly what happened!! We were learning how to change the color of the backside of a surface…turns out when you change Backface Settings (i.e. your screenshot above) from “Use front face settings” to “Custom material for all objects” the smooth surface becomes ever so slightly tiled (resulting in jagged zebra lines). In the class our instructor changed the setting back, but I didn’t and so the problem persisted. Thought you would like to know!!

Ha thanks!

Hi Kate - thanks for the details - I can reproduce what you show above if I set the custom backface material to use flat shading - is that how you had it?


Hi Pascal,
Flat shading was never turned on. Look what happens to smoothness of surface in screenshots when ‘backface setting’ changes from ‘use front face settings’ to ‘custom material for all backspaces’.

Hi Kate - can you poke the Customize button for the custom material? Is there flat shading set in the custom material?


Ha! On this screen the flat shading is on! What does this mean?

Hi Kate - thanks - that is the bug - ideally that setting should not affect the front face settings but apparently it does… and I do not know if it is even possible to shade these independently (smooth on one side/flat on the other) . I’ll put it on the pile for a developer to look at - thanks for pointing this out.


Interesting. I guess we both learned something new!! Thank you and have a great day :slight_smile:

1 Like