Rendering when Water with Ripples isn't and Navy is gray

Rendering in R6 and R7, I’m having difficulty with materials. In the attached, the hull above the boot top is Navy plastic and the ground plane is “Water with Ripples”.

I’m trying to learn Rhino Render.

Both materials are brought into the model using “Import from Library”.

You have to change the size of the mapping of water with ripples. You probably have created your model in a millimeter template or similar.

***Note that as I write this I am having trouble with the ripples showing up with a ‘custom’ based material (waves not showing up when I render), and the displacement is going mad with the physically based material. So the ripples without displacement is the best I can get (for ripples).

Also note that I should have done this in R7 not R8… maybe I can upload something later though.

You can also use procedural materials. I think that rippled water might actually be procedural.
It’s not obvious what to use. This quick render uses the “noise” texture.
This is using the “ripple” texture:

If you’re starting with the material library’s rippled water, you’ll need to find this:

Then this (change linear to radial):


Depending on the size/shape of your water you’ll need to adjust the repeat and mapping (and maybe offset):

Note that I had to use the physically based material to actually get the ripples to show not custom.

This might be a hint to why it’s not working. I was very sloppy cutting the boat’s hull out of my water surface:


Custom material is a bit broken in Rhino 8 at the moment, but you can change the material type to Physically Based (it is better anyway).

I’m trying to render in R6 and R7. How do I change the size of the mapping?

No matter which settings I’ve changed, all I get is sandpaper with no color.

You should follow the instructions here Rendering when Water with Ripples isn't and Navy is gray - #3 by keithscadservices

Sadly, the instructions there are created in R8, which I don’t have. The dialogs appear quite different and I don’t find any of the settings shown, after the dialog that shows the bump/normal field.

It doesn’t help that I was in a bit of a hurry… and in R8 of course. I’ll be able to have a crack at it in R7 either tonight or tomorrow AM. I can just screen cast whatever I do. Navigating through the materials menu(s) to the place where you actually control the texture size isn’t the easiest at first.

1 Like

The dialog does in fact have some key differences which aren’t really easy to describe.

The linked video is R7 and should be enough to get you going. I thought for sure there’d be a good video on this but I couldn’t find anything. So just threw this together. One tip is that once you go into the texture, the only way I know to go back one level is to click on the material’s icon.

One thing I didn’t/should’ve done is use the physically-based with the texture linked to both bump and displacement (seems like the best way but I haven’t been able to get good results yet). In the video I create a render mesh using the displacement in the object properties. This seems to work but you need good hardware. There’s a lot more you can do, especially with Grasshopper. But it gets time-intensive.

Displacement won’t work in a useful manner on the groundplane - it has not enough density for it to look as expected.

Displacement you should use really only when you need a close up, and then generally you’d put only on part of the object. Displacement needs a dense mesh to look any good.

1 Like

I should have tried with the ground plane. That’s a little different compared to working with an actual surface. And it’s proving a little harder than anticipated to get the ripples to show up. I used the checker pattern for a reference (you have to either use very small or large values depending on your mapping settings):

Here’s the turbulence texture:


It appears to be non-seamless.

I get the best result using the leather grain pattern go figure:

Leather Grain Water.3dm (1.3 MB)

In Rhino 7 it will not be seamless as back then Rhino Render / Raytraced didn’t support Rhino procedural textures natively. Instead those would be baked to image files.

In Rhino 8 such textures are infinite, seamless.

1 Like

I really like the appearance in the rendered viewport., but in the render it comes out with almost no pattern at all.

I dropped my 17 1/2 foot row boat (units = inches) into your leather-based model, hid the sphere, and raised the ground plane to 15" and it looks great, again, until I render it.

Above is my model in the leather-based water in a rendered viewport.

This is the same model rendered. It looks like water, but not nearly as “active” as the rendered viewport. Is this an environment setting in render properties (R7)

In desparation, I back saved and opened up my original file in Rhino 5. In R5, I am able to run Flamingo nXt and the ability to manipulate the water material is almost astounding, compared to the sandpaper I’ve been achieving in R6 & R7 with Rhino Render.

This render involved making a few clicks in the Flamingo material editor and, mostly, trying (unsuccessfully) to get the clouds to look right. The water texture was amazingly easy.

Is there no provision for procedural materials in Rhino Render?

Finally, this is my boat in your leather-based model

Whitehall in Leather Grain Water.3dm (5.0 MB)

1 Like

Thanks for the help.

I sincerely appreciate the effort on the video, but on my Surface Pro 8, I can’t see what’s going on, unless I zoom way in and that puts everything out of focus.

I used to be able to view videos readily, until my desktop went south.

1 Like

It’s a bit of a downer when the rendered view (which is a render “preview” I guess) looks worse than the final rendered result.
I chalk up my lack of results on my hardware. But then I realize that my hardware would have been quite powerful in R5’s time. Some people are getting really professional results using Cycles. But most people use some sort of 3rd party rendering engine.

For better or worse these are the procedural materials. I’ve gotten mixed results with them. And sometimes have had to use some unconventional approaches. I’ve been working on a scene for a backyard swimming pool which is why I bit on this… already having dealt with lots of what you’re dealing with.