Rendering Mode vs Raytraced

raytraced

#1

Hi all

I get a weird result with Rhino 6 Beta in raytraced mode

Here s a comparison of my image maps between the 2 view modes


#2

One is in rendering mode and works nice but raytraced mode yields the second result


#3

it looks like you are missing an environmental map in the rendering or a standard light.
maybe there is a setting for it.


(Nathan 'jesterKing' Letwory) #4

Can you please share the model with me so that I can investigate if there is a bug? You share it with me using [rhino3d.com/upload](rhino3d.com/upload. In the recipient field use my address nathan@mcneel.com - that way I get automatically notified when the upload is ready for me.

Did you use decals for the prints on the body?

/Nathan


(Nathan 'jesterKing' Letwory) #5

FYI, I have received the file.


#6

it s not the lighting the issue but the image mapping
In raytraced mode it came out random compared to Rendered mode


(Nathan 'jesterKing' Letwory) #7

I am not exactly sure how this matters, but using Planar (UVW) has the texture mapping coordinates get properly created. I’ll have to ask @Jussi_Aaltonen for more information.


(Jussi Aaltonen) #8

@alexandre_galin I can see a similar problem here with a simpler model. Few questions:

  1. Is your model all nurbs geometry or are there meshes as well?
  2. Does your model use Displacement or Shut Lining?
  3. Do you have Displacement plug-in loaded or not?

#9

Hi Jussi

the answer to all your questions are No

It s all nurbs there are no meshes, no displacement nor shut lining applied

thanks for your inquiry

Alex


#10

interesting Nathan. Thanks for looking at the issue.

Alex


(Pascal Golay) #11

@Jussi_Aaltonen, @nathanletwory - I see a similar thing here - raytraced only sees surface mapping even when Box mapping is applied, in my example - I’ll attach the file in case it helps.


RaytracedMapping.3dm (4.2 MB)
BTW, kind of a large file, looks like a lot of RDK data - is that legit here?

-Pascal


(Nathan 'jesterKing' Letwory) #12

Audit3dmFile indeed says a whopping lot of RDK bytes. I’ll mention it to @andy for investigation


#13

The same here.
Vittorio


(Jussi Aaltonen) #14

Hi Alex,

I can see 2 problems with the racing car model:

  1. Shut Lining somehow causes the texture mapping to go nuts. Turning Shut Lining off for all objects fixes the mapping. This is clearly a bug.
  2. Even without Shut Lining: texture quality in Raytraced view looks much lower than on Rendered view. @nathanletwory, is this expected?
  • Jussi -

#15

HI Jussi,

ok I forgot ,I guess, I applied shut lining to my model. Anyways I m glad you guys are looking at it.

thanks for the updates,

All the best,

Alex


(Nathan 'jesterKing' Letwory) #16

Hmm, I didn’t turn off shutlining, just changed to UVW planar, but from what I can see sampling qualities are comparable:

Higher resolution textures would yield better results for both modes.

/Nathan


(Jussi Aaltonen) #17

Sorry @nathanletwory, only now I fully understood your first post. Yes, planar (UVW) is a 3d texture mapping and therefore uses texture baking. And it gives the same texture quality for both Rendered and Raytraced when baking resolution is the same.


(Nathan 'jesterKing' Letwory) #18

@Jussi_Aaltonen I always receive baked texture coordinates through the changequeue.


(Nathan 'jesterKing' Letwory) #19

I found a bug where the texture gets created improperly (height and width swapped), resulting in very bad render resolution: RH-42574. Another bug related to Planar (UV) vs Planar (UVW) was reported as RH-42547.


(Dan Belcher) #20

RH-42547 and RH-42574 should be fixed in the latest BETA. Please give it a try.

A related bug - RH-42538 - should also be fixed as well.