Rendering Mesh Colors


I’m wondering if there is any method, extant or planned, for rendering mesh colors in Cycles?
Anyone have a method for getting it to work?


There is a material behind the TestShowPrivateContent that, when applied, renders vertex colors.

Hi Nathan thanks for the quick reply,

Not sure what i’m looking for is that in one of the material folders? Is that a command?

thanks for the help

Hi Nathan,

Alright sorry about that, figured it out and applied the material but its not rendering vertex colors in raytrace view, only in rendered view,

ive included screenshots, its from a force flow study on a climbers skeleton done in grasshopper, output is colored mesh

Type the command TestShowPrivateContent. This will show ‘secret’ Cycles/Raytraced materials. You should add a material of type Cycles VertexColor, and apply that to your object.

Here a quick demo with a vertex-painted Suzanne, exported from Blender.

If this still doesn’t work, could you please share your 3dm with baked skeleton model with me? If you don’t want to share it publicly you can use to share privately with me. Use as the recipient.


1 Like

thanks nathan, here it isclimber_skeleton_forces.3dm (1.3 MB)

After applying the vertex color material to all meshes I get this (and setting a gradient as bg color):

Hi Nathan,

Still not working on my end.
I thought maybe I’d update to latest version, now running BETA 6.0.17325.8311, 11/21/2017
Another curve ball is I can’t seem to be able to select Rhino Cycles as current Renderer anymore, its not listed under available renderers,

thanks again for your help

Cycles for Rhino (CfR) indeed is no longer available as current renderer, but the very same render engine is Raytraced. This is because CfR won’t be part of the final v6, and we thought it better to not have it linger around in the BETA confusing people.

I’ll update to latest BETA as well, this rendering at least works in my local build.


Ok cool, not sure why it continues not to work in my raytraced view, it is rendering the vertex colors in rendered view and with rhino renderer but not at all in raytraced, this is my systeminfo if it helps

Rhino 6 SR0 2017-11-21 (Rhino WIP, 6.0.17325.8311

Windows 8.1 (Physical RAM: 16Gb)

GeForce GT 750M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 368.81)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 7-10-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino BETA\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino BETA\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino BETA\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino BETA\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino BETA\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino BETA\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino BETA\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino BETA\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino BETA\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino BETA\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino BETA\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino BETA\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino BETA\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino BETA\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino BETA\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino BETA\Plug-ins\Displacement.rhp “Displacement”

This is quite old. You should be able to get newer drivers for your card:

Please try updating them to see if that helps with possibly CUDA support improvements.


updated and re-started, still no luck, anything else i might try? not mission critical to be able to render them but would save a boatload of work

Not sure what is going on, but when I start Raytraced not all meshes render properly, but if I select all objetcs and assign the material again while Raytraced is running things look much better. Maybe that will work for you for now?

If that also doesn’t work, can you still try with CPU as the render device? Change it through Tools > Options > Cycles before switching to Raytraced.

Tried it with CPU and still no luck, it seems as though raytrace isnt rendering any materials at all now

Not sure what to suggest at this point, perhaps, as a shot in the dark, try repairing your Rhino BETA install?

Or maybe before you try that, can you try importing attached FBX file, and assign the mesh a Vertex Color material? (66.5 KB)

Hi Nathanletwory,

Can you -viewcapturetofile out of raytraced view? I’m attempting this but getting all black jpeg’s,
also will Cycles be available for purchase as a rendering engine after release?


The ViewCaptureTo* commands should work. If you use a resolution different from the viewport you should be getting a rendering done by the modal renderer (you’ll get a progress bar dialog), which is the very same mechanism as the render window rendering conducted by Cycles.

I’ll ask @andy and @marika if they can capture fine, they both have a GT 750M in our office IIRC.

In the meantime you could try forcing Cycles/Raytraced to not using OpenGL: open Tools»Options»Advanced and type UseDrawOpenGl. Toggle it so it says false. Then switch a viewport to Raytraced and see if your regular ViewCaptureToFile works better.

Regarding Cycles availability for purchase I doubt it. It won’t be in V6, but the next WIP should be available a or around the release of V6, in which you will have access to CfR without additional cost.


Right on I’ll give that a shot,
Thanks for your help Nathan,

No problem - I don’t like it when Raytraced doesn’t work, so I’ll try my best to find a solution!

Hey how can I render vertex colors after all the “recent” changes to the rhino rendered viewport/cycles ?