Rendering - low quality files

Hi, I tried rendering function and export PNG but will the files came out in low quality, under 1MB, blurry when zoom in. I compared my resolution and quality settings with a friend of mine, they are the same but she exported around 10MB files. I chose viewport resolution, (tried much higher options too but worked the same) both draft and good quality (50 and 500 sample).

I ticked Denoise as well. Can someone help me with this? Thank you.

Hello - please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

Thanks Pascal. Here it is

Rhino 8 SR5 2024-3-12 (Rhino 8, 8.5.24072.13001, Git hash:master @ e3530849b75f00b2b977766a567ae29b055837e9)
License type: Evaluation, build 2024-03-12
License details: Cloud Zoo
Expires on: 2024-05-17

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: LAPTOP - Unplugged [98% battery remaining] ~349 minutes left

Standard graphics configuration.
Primary display and OpenGL: Intel(R) Arc™ Graphics (Intel) Memory: 128MB, Driver date: 3-5-2024 (M-D-Y). OpenGL Ver: 4.6.0 - Build 31.0.101.5334
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: Intel(R) Arc™ Graphics (Intel) Memory: 128MB, Driver date: 3-5-2024 (M-D-Y). OpenGL Ver: 4.6.0 - Build 31.0.101.5334
> Integrated (slow!) graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build 31.0.101.5334
Driver Date: 3-5-2024
Driver Version: 31.0.101.5334
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 128 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hello - is the saved image of the expected dimensions in pixels?

-Pascal

Yes, its 1842x1272. When I saw it gets blurred when zoomed in I changed to 2k 2048x1080 result was not much different. Is there a specific setting (camera or something) that can affect this? I want to be able to zoom in to details like stair rail, wall bricks…

What happens if you copy the render out of the render window and into something like Photoshop or GIMP?

I get some silly results sometimes in Rhino 8 when saving images using Rhino natively, so I just skip that and copy the render window directly to GIMP.

Hi Ive just tried to paste it into PSD, looks decent from afar but breaks after 5 zooms :frowning:

What do you mean by “it breaks”? 2048x1080 is, by modern standards, pretty low-res, and artifacts will show up as soon as you start zooming in. At 300 dpi it’s just 17x9 cm, and on a modern 4K monitor it takes up just about 1/4 of the screen. If you need to zoom in on your renderings you need to render at a much higher resolution. We usually render at ~5500x4000 for A4-size images to make sure that we can crop the edges to fit whatever layout we need.
HTH, Jakob

It’s not a bad render as such, but I can sort of understand what you mean. There may be a few things to check here:

  • Check your object isn’t far from origin (not sure this is the problem)
  • Check that you don’t have a Depth of Field Effect applied in the DOF tab in the viewport window or your render settings.
  • Check for overlapping geometry.

I can sort of see some shadows that look like artefacts or such. But it could be texturing.

I can see that there is perhaps vertical pixel shearing going on in your zoomed out image (this was a Rhino bug). However the rest looks either like one of the above problems, or a compression issue.

If you need to maintain your privacy, then you can always hide the rest of the geometry, and leave a wall, a window, and then just export those to the forum, and others can have a look. Try and save the camera in a position you think has a problem, and we can reproduce the problem easily.

Otherwise, it is as Jakob said, that the images may well lose quality, as 1080p is good, but is clearly aging now as a resolution.

Thank you Jakob.

Hi again David, I tried but I cant upload my file as it’s way over 20MB. Any other ways I can show the whole file so you can help me look into it?

You can upload it and post a link to an online drive (Onedrive, Google drive… etc.). Or, if you just want McNeel to look at it, you can email your file to them.

However, normally, just delete whatever you can out of the file to get to a minimum working example of your problems, erasing materials, environments, and then using the purge command. Then you can check if you can still see the unsatisfactory rendering issues, and then post that smaller file here.

Thank you David!