Rendering grasshopper animation kangaroo

Hi!

I made this model it is a stl file combined with a rhino / grasshopper animation. The red part is behaving as an inflatable. I want to render this since now it does not look very nice but I really have no clue how to do it since it is an animation. I saw something about Vray but I can not get it work and I am quite new to the software of Rhino.

So if you could give me some tips would great! And it can be basic rendering since I am not experienced at all.

Screenshot 2021-05-20 at 13.45.53

Hi @cayakors

For rendering animations I usually use the rendered viewport mode with custom preview components in Grasshopper, and the StepSolver.

I’ll create a material in Rhino, then reference it in the material input of the ‘Custom Preview’ component.

To test the simulation I’ll use the regular solver or bouncy solver component, then when I want to render the frames out, I’ll use the ‘StepSolver’ component. (disabling the other solver first - it’s best to only have one solver component on the canvas active at a time)

If you connect a slider to the Animate input, you can then right click it and choose the resolution/how many frames etc.
The ‘SubIterations’ input can be used to control how many simulation steps it takes between each rendered frame.
If ‘Momentum’ is False, it solves like the regular solver, trying to reach equilibrium quickly, and if it is True, it works like the Bouncy Solver.


ballooncollapse_anim.gh (26.2 KB)

2 Likes

Hey!

How do you reference your material? I added the wbLoop, but I am not able to assign a material because then the animation won’t run anymore
car model - execution 1 - 3 v2 render.3dm (5.6 MB)
test inflate_anchor_v5 render gh.gh (18.3 KB)

Thanks for the tips

Hi @cayakors

You can create or import the material in Rhino first from the Materials tab.
Then in Grasshopper on the Custom Preview component, the materials in the Rhino doc should show up by name under Set one material

In the animation above I also set a custom environment for reflections in the rendering options

also - don’t forget to turn off the grasshopper preview on the components before the custom preview, otherwise they will affect the colour.