RenderedViewport display bug


#1

Hi @pascal,

using a “custom material” with a texture and bump in their slots does not display properly anymore in the rendered viewport. It turns the material into something transparent.

If i switch to shaded display mode, then use _SetObjectDisplay mode and set both objects to use _Rendered, it looks how it should…

c.


(Pascal Golay) #2

Yikes! - I do not see that here - I made a box, made a new material with an image in Color and the same one in Bump, set the view to Rendered - does that sound like it should show the problem? Here this looks correct. I guess if you can send me your objects with materials & textures it would be best, maybe there is something I’m missing in my test…
Ah, wait, if I turn the color channel to less than 100% I start to see transparency - I’ll dig into it.

https://mcneel.myjetbrains.com/youtrack/issue/RH-38099

thanks!

-Pascal


#3

Hi Pascal,

it happens if you take eg. a black and white image in the color slot, and set the masking option of the texture to use white color. I’ve also set the channel intensity to 50% but that should not matter:

When rendered with cycles, i get what i expect. The white color is made transparent by 50% and the green material color starts to shine through:

c.


#4

Oh yeah, just found that the 50% is what makes it happen not the color masking. Thanks for adding it to YT.

c.


(Brian Gillespie) #6

RH-38099 is fixed in the latest WIP