Rendered viewport transparency weirdness

Transparent materials in the rendered viewport mode aren’t working right. This is using a glass material:

Raytraced renders correctly:

I don’t know if it has anything to do with the fact that the rendered viewport can’t find the texture for the floor. I am working on this at home from my USB drive, and if I look at the path to the texture, Rhino has found the correct location (only the drive letter changed), and cycles is rendering it. Also, Rendered viewport is rendering the wood texture OK, so its a mystery as well why it isn’t finding the floor texture.

Cabinet.3dm (2.4 MB)

The “V1 - Blackbutt veneer clear” material has ‘alpha transparency’ enabled in the material’s advanced settings. This is also the case for material “Terazzo”. Disable the feature for either and the issue is fixed.

Looks like the OpenGL display of Terazzo has something to do with the tga in the bump channel needing to be reloaded. Toggle the bump texture and it should display… not sure how this happened so far but I’ll try and repro for a bug. Thanks.

1 Like

Both issues fixed! Thanks Brian.