Rendered view suddenly looks amazing, but how?

I have one model which produce a very noisy real-time rendered result:


Then I have a different model which produces an amazingly crisp real-time rendered result with even directional shadows:


For both models, I haven’t changed any settings. The noisy model comes from a 10mb STEP file and the super smooth model comes from a 20mb IGS file, so they’re of a similar rather high complexity.

(I can’t show more due to these being highly sensitive.)

Why do they produce such a significant difference in the rendered view quality?

Hello - can you put a few surfaces from one into the other and see if it all still looks good in the same file? Can you post a few surfaces from each?


I imported the entire model from the first (noisy) file into the second (clean) file, and it also became super clean.

The noise render seems like a true offline pathtracer, while the clean render seems like a realtime 3d accelerated mode (similar to the difference between Cycles and Eevee in Blender).

How do I switch between these two modes?

I found the View - Display Modes - Raytraced settings, but there’s tonnes of them in there.

If you make a r10 sphere in each and export that into a new Rhino file then the settings should be exported too and this you should be able to share. (Just make sure «notes» are empty)

If I add a sphere to both files, and then delete everything from all layers, the noisy file is still 80mb large and the clean one is 300kb…

Also, I just noticed that the noisy rendered view throws a diffuse shadow on the ground, while the clean rendered view doesn’t throw any shadow on the ground (clearly does throw shadows on itself).

Then it’s probably the environment setting. The noisy one uses v6 default and the clean one uses a v5 style.
But 80 Mb was big though… type purge and hit enter. That will clear out any block definitions too.

1 Like

Thank you, that reduced the size!

We only recently got into Rhino, so V6 is the first version we bought.

noisy.3dm (291.9 KB)
clean.3dm (299.0 KB)

I presume it is the code for opening IGES vs STEP that causes this. DWG defaults to V5 style too.
@pascal can you verify that? And it would be handy to have a “set V5 style environment” in V6 since often this yields a higher fps on complex files.

It is one of the things I have wondered about for a long time, but never gotten around to address. And Pascal do you know why is one shading like V5 when both seems to have the same environment?

You might be on to something there, because the noisy example is indeed a STEP import while the clean example is an IGES import!

So how do I convert the noisy environment to the clean one?

And is it possible to add a ground shadow in the clean view?

Well… AFAIK there is no “make a v5 style environment option” so then the solution would be to open the “clean.3dm” file, delete the sphere and then IMPORT the STEP file into that one. You might want to double check the file tolerance and unit size first though.
Or copy-paste the content from one file to another. You can have two instances of Rhino open so it is easy to copy-paste from one to another.

A related topic regarding opening FBX files:

(It makes the same V5 style look, but here I wish for the much smoother V6 stile as the grainyness doesn’t bother me)

I came across this again, where an imported file produced the clean rather than the noisy render, which made me remember that I was given the solution in another thread:

However, this button only works to go from clean to noisy. There’s no similar button to go from noisy to clean.