Removing grid lines from meshes

Hey there!
I converted a cityGML file to 3dm and by default it looks like you can see in the first picture.
The buildings are individual meshes that all have these diagonal lines running through the main surfaces.

When I switch the view and hide the grid lines, the diagonal lines disappear and the buldings are displayed clean.
Now I want to deconstruct the building with grasshopper and want to work with these clean surfaces like shown before. How can I get these surfaces?
I tried things like deconstructing the mesh, converting to breps etc. but the surfaces are always split up. But the fact that rhino can display the buildings in a clean way proves that there is some differentiation between the vertices, otherwise it wouldn´t know which ones to hide or show.
I am using Rhino 7 btw.

Thank you in advance!
P.S. if you have a workflow with cityGML files I would be interested to hear about it!

Did you try MergeAllCoplanarFaces?

Thank you for the suggestion.
Merging the faces helps but unfortunately does not go all the way. The picture I posted here shows three copies of the same building.

  1. is the unedited mesh with hidden grid lines in the display settings.
  2. is using AddNgonsToMesh
  3. is using MergeAllCoplanarFaces

Like I said, it helps but does not do the full job!

Could you save one or two of the buildings as a 3dm and post the file here?

644_5482 Subsample.3dm (157.2 KB)

Thanks for helping! I posted a subsampled file!

Calling Vertices.CombineIdentical before MergeAllCoplanarFaces with a tolerance seems to do the trick: (3.7 KB)

1 Like

Thank you very much! Not only for the solution but also the very fast responses!
I would´ve never come up with something like this!