Removing duplicate lines

I’m trying to remove duplicate overlapping lines in an isotrimmed lofted surface using cull duplicates points. However, only the outer profile lines are getting selected.


What should I do?

“Leave One” ofCull Duplicatesshould work.


Right-click on Cull Duplicates and choose ‘Leave One’.

1 Like

Thanks! It worked. However, I’m confused about the principle behind this. The same points get selected in both the cases (i.e. ‘average’ and ‘leave one’ )but lines that get selected are different.

Please help me understand.

If you have LunchBox try this:

If you leave the option “Average” by default, you can find a bunch of “-1” in the “I” output result.
These “-1” means they are newly created points and thus they have no indices, so “-1” was given.
Whereas if you choose “Leave One”, then Cull Duplicates only remove one of duplicates and you can find the existing indices without “-1”. and by using them, you can choose the single edges from the flattened edge list.

1 Like

Okay I see. Your knowledge is magical. :+1:

There should be some information inside Grasshopper for negative values so that it gets less difficult to use. :grinning: