Reflectivity emitting light - or just reflecting any light unconstrained

I might just not understand how it’s supposed to work, but to me it seems like there’s a problem with reflectivity in R6.6. Materials with reflectivity “shines” like it was itself emitting light if any, even the slightest, lights source is in the model.

No matter how little or weak, it still shines/reflects like it was hit with 100% light strength. See example below.

In this model there’s one little weak light source (2% linear light), shining down towards the book shelves with the light source covered on top (the upper hemisphere of the light source is covered, or, at least it’s meant to be so), but still the chrome pipe (from the stove-stub) is shining like it would be a light in itself:

Fig 1. No lights on:

Fig 2. One tiny little “linear light” (2%) on. Desk and Chrome pipe is “shining unconstrained” kindof:

Am I totally off, missing something essential?

// Rolf

That looks like a material that has self-illumination checked.

Not according to the UI anyway (I selected the stove-pipe (chome) and the desk, which both has reflectivity. Only if I drag down reflectivity the “self-illumination” goes down. Same problem with the brass metal handles on the desk drawers, everything metal seems to illuminate, or it seems, things with reflectivity (?).

Same view without selection:

Forgot to point out that this is not Raytraced, it’s Rhino render.

// Rolf

I just tried switching to Raytraced, but then Rhino crashed without crash notification.

// Rolf

Ugh, not good. Check if there is any RhinoCrashDump.dmp and similarly named files, zip them and upload at with as recipient. Thanks.

Anyway, the problem here are the environments. They are most likely still sampled at 1.0 strength. A bit of a drawback with the current environment system.

You can test with a simple sphere scene that has metal. Groundplane set to default material. Simple linear light at 2% intensity. Custom reflection and skylight env set to the default rhino studio env. Now set the skylight strength to 0.02. Observe. Turn off skylight. Observe.

Do the same with the skylight intensity set to 1.0

I’ve got this (searhcing with “Everything”):

I may have sent a crash notification yesterday (then the dialog came up when it crashed).

The model is very messy since it’s only a quick and dirty illustration thingy of my daughter’s “visions” of a new house ( to be built in Finland). Modified a thousand times…

// Rolf

I need only the dmp, the 3dm may help seeing the model that caused the problem, thus help me understand.

No enviroments.

// Rolf

Btw, I am not saying current results are correct. Just trying to tell how it does work.

I do notice some extra irregularities, I’ll poke @DavidEranen about it Monday after Juhannus/Midsommer holidays are over

1 Like

No problem. This is not a big problem right now in this case (just a quick and dirty mockup).

Have a pleasant midsummer evening!

// Rolf

For now, as a work around, I suggest you use the same HDR environment in custom refl and skylight, then turn the skylight to the intensity you want, and then turn it off - that should have the strength stick also in the reflection. That way your pole won’t stick out so much ^.^


1 Like