Is there a way to save the ray traced render other than [ViewCaptureToFile] or [ViewCaptureToClipboard]?
Is there a way to have this done in the background? (i.e. be able to continue working/modelling)
When ViewCapturing with transparent background, I would expected that there would be an alpha channel or something, but it does not. Is there a way of doing this?
I also found that when [ViewCaptureToFile] the shadows in the ground are gone and the only way of getting them is to [ViewCaptureToClipboard].

Any help would be welcomed,

Yes, but it is kinda behind a test command. Use _TestPackageManager, then select to install the rhino-render-next package. Restart Rhino. Now you should have a new renderer to select as the current renderer: Rhino Render Next. This gives you access to essentially Raytraced through the _Render command.

Not at the moment.

It should work also with the _ViewCapture* commands.

Here there should be no difference. I’ll be testing this later today to ensure it all works still.

/Nathan, the friendly Raytraced dev.

Thank you Nathan,
Maybe I am missing something but the _ViewCaptureToFile command saves as JPG (or is there a way of changing this?) and therefore no alpha channel. And with the ViewCaptureToClipboard how would a alpha channel be there?
What I mean is that it is true that it does not render the background and ground (stays black) but it is not transparent. I.e. we still need to select the black (and grey for the ground shadows), but that may mess other areas of the rendered scene.

I’m sorry if I am missing something basic but I just started playing with this (and with a deadline going on :wink: ), and there’s loads of new things on Rhino 6 visualization.

Thanks, N

Use the dashed version (-ViewCaptureToFile), then you can set the file name - give one with .png and it should save as PNG.

Not sure about the clipboard version, haven’t really tested that before with alpha channel.

Hi Nathan,
Neither the PNG and the Tif appear to have alpha channels or transparency.
I have now used -ViewCaptureToFile
So far only the ViewToClipboard appear with a black background and ground (which in this particular case is the best to remove the background).
Nevertheless, it does not appear to be working as expected.
Any other ideas. Again as these are my first tries I may be missing something glaringly obvious…
Thanks, N

Hello - did you set up ‘Transparent background’ in the capture? Just making sure…


Hi Pascal, Nathan,
Apologies. I am sure I had ‘Transparent Background’ on my first attempts, but it was saving as JPG, therefore no alpha channels. Then I did not notice that the setting resets after closing Rhino and reopen to test the dash command. Both the PGN and the TIF have transparent backgrounds. I have not tested the floor shadow yet. but I am in the process of doing it.
Thanks, N

Hi Nathan,
Is there a way of rendering just a small window of the viewport for checking?
I have a file that is not that large (62Mb) and four materials and it is taking several hours to render. I am doing this on a less than optimal machine (Surface Pro4) but there may be something else dragging?
Thanks, N

There is unfortunately not yet support for rendering just a part of a view. That is something that will happen for v7.