Raytraced viewmode feedback


#1

Hi @nathanletwory

I like how things are going with the raytraced mode, and here are a few comments:

1 - It seems that the default amount of iterations is 10.000 and that is overkill imo. 1000 makes more sense at least for laptops and not superpowerful machines.

2 - 4K monitors have a lot of pixles so when the default “pixle size” when orbiting (first pass) is 1 px that makes navigating even a simple object with a glass material really slow.

3 - My laptop has a slower gpu but still a high res monitor so I would really like the ability to set the raytraced resolution to 1/2 or even 1/4 (but have crisp curves and wireframe drawn on top if possible). Otherwise it is not possible to use it in maximized view mode. (graphiccard is a geforce 750m, and the cpu is a 4 core i7, their speed performance is about the same)


(Nathan 'jesterKing' Letwory) #2

You can use RhinoCycles_SetRenderOptions to set a new default. This is now an application setting, persisted between sessions.

@andy, more feedback regarding the 10k samples here :slight_smile:

I’m not sure I follow entirely your point. Are you saying you want a more grained version to start with?

I have created a YouTrack issue for an idea we discussed internally earlier this week that might help with the progressive refine becoming snappier:

https://mcneel.myjetbrains.com/youtrack/issue/RH-38467

So you want to render at lower resolution, but scale the result up to fit the viewport? edit: created https://mcneel.myjetbrains.com/youtrack/issue/RH-38468 for this to track.

Note that issues target release is set to 6.x, but once I’m done with my 6.0 issues I’ll continue picking off what I can before Rhino v6.0 release.


#4

Yes, I would like a low res setting for the viewport.
(Compare it to pkaying a game on lower resolution and higher frame rates vs high resolution and low framerate, or streaming a video on a slow internet connection, 30fps at 720p can be much more enjoyable than 5fps 4k :wink: )

And there are some transparency issues with cycles:
Check out the glass, it is a default material with green color and 98% transparency, so it should be just slightly tinted green:

Also environment materials assigned to the material (not environment) is not shown in Raytraced. I didn’t expect it to, but I did expect it to show the environment map when edited:

Here is a new file with two new materials, one custom and one metall:

Also editing materials are really slow.

Btw I get about 2 fps on that file on my Geforce 970. In OpenGL I get closer to 20.

None the less, great progress and keep up the fabulous work!!!

(Got to run now, so I can’t reply in a few hours)


(Nathan 'jesterKing' Letwory) #5

I’m now (finally) working on:

https://mcneel.myjetbrains.com/youtrack/issue/RH-37339
https://mcneel.myjetbrains.com/youtrack/issue/RH-38199

These two issues encompass all the errors you mentioned.


(Nathan 'jesterKing' Letwory) #6

Note that for a correct metal created with Custom you need to have the Color channel set to black. You can see this automatically happens when you convert your metal to custom.