Rasterized detail in vector output mode in layout

Dear all,

I have run into a mistake/bug, which I can’t replicate. But this strange behaviour is what I was looking for and can be a huge advantage in speeding up my workflow.

Lets start by saying that I am an architect, and the biggest issue in using Rhino is that I had to go through the process of updating 2d drawings or using ViewCapturetoFile to get nice illustrations. I am missing the functionality of Revit or Sketchup where the documentation is updated automatically within the layout tabs.

While printing layouts in “raster output”, everything on the layout page (including 2d linework of details, texts, logo etc) is rasterized:

When printing in “vector output” all details using for example “rendered display mode” are represented as lines without shading, clipping planes etc:

It now seems that I have changed something in one of my display modes, that forces Rhino to rasterize the viewport/detail using that display mode, even when I am printing with “Vector output”. That is actually really great, because I could mix 2d linework, texts, dimensions etc. in vector graphics, while being able to implement “up to date” screenshots on the same page without using ViewCapturetoFile and re-importing bitmap as “Picture frame”. See here - this is a layout printed with “Vector output”, 3 details are rasterized while everything else is vector output with real text:

Because I don’t know what is actually happening, I am afraid that I will loose that functionality in one of the updates. Could you explain why is that happening or maybe implement function “Force raster output” in display mode?

Thank you

Hi Pawel - - I think that is just how it is supposed to work - individual details that are in some raster/shaded display mode will be printed as raster and ‘wire’ details will be vector. If you re-import the file to Rhino, you’ll see the raster details are ‘Pictures’

-Pascal

Hi Pascal,

Thank you again for responding to my questions.
The reason that I am asking this is that in Rhino version 5, when printing with “vector output” all details was looking like the second picture I provided.

Have a look here:


I have created layout with 2 details which are exact copies of each other. The only difference of the two is the display mode that those are using. I am printing that layout in “Vector output”. You can see in the preview that the one marked in blue is behaving as it used to do in version 5 - the print output are vector lines without shading/clipping. The one on the right (marked green) is printed in raster.
The question is: how to force a specific display mode or detail to be rasterized? Is there a specific parameter that is doing this?

Having the same issue here with rhino 8.
I wish we could print vector and keep the lines as vector but have the image visible as raster. When i use the standard display view mode (Rendered) and print as vector then the output will be fully raster.

1 Like

Hey Maxime -

In Rhino 8, viewports (including details) that are in any of the technical display modes (Technical, Monochrome, Pen, Artistic, and any copy thereof) will result in vector output with hidden line removal when printed to vector PDF.

You can use Picture objects or overlay details in a technical display mode over details in shaded display modes to achieve a combination of raster and vector.

image
→ A Rhino layout with a detail in Shaded and a detail in Technical.


→ A PDF file showing vector on top of raster

-wim

1 Like