R7 low hardware usage, viewport low FPS

Hi everyone. I am new to Rhino.
I just built a computer with the following specs:

  • Corsair Rm 850i
  • Ryzen 9 5900x
  • Vengeance 4x16gb DDR4 3200Mhz CL15
  • ZOTAC RTX 3090 Trinity 24gb
  • Sabrent 256gb Nvme SSD
  • Windows 10 with latest updates
  • Nvidia Studio Driver 460.89 DCH

So, i am trying out Rhino 7 with iray. I’m used to another software (pCon planner), which used Intel OSPRay / Yafaray engine.

I was able to import the project I am interested in right now from pCon planner, as it is a .dwg file. I had to re-assign the materials but I didn’t have any problem doing it. The project is medium sized and not very detailed.

I was told the viewport usually uses GPU. With this project, i notice that real time Iray rendering is actually faster than the wireframe view. the wireframe view gives me very low FPS on this project. GPU tessellation is active though.
During viewport i use 12% of the CPU (4 threads 100%, the other idling) and around 3% of the GPU.
Using Iray, the cpu spikes up to 100%. Gpu 3-5%.

So now I noticed that based on the settings I use, I use more or less CPU but the GPU % is usually the same.
If I use the cpu only, it uses it at 100%.
If I use CUDA settings, it uses the gpu up to 10% (and it’s faster than the CPU)
If I use Optix settings, it uses the CPU up to 12% (4 threads) and the GPU 5-7%.

So after describing my situation, my only concerns are:

  • To make sure that I can use my hardware correctly during viewport, so that handling the project becomes smooth.
  • Finding a plug-in render engine that can use my GPU and RTX tecnology for my renders. I was thinking about V-ray 5, but I didn’t test it out yet.

Do you have any advice? Let me know if you need more info!
Thank you!

If you use the Task Manager to determine GPU usage you should ensure that CUDA or Compute is selected instead of 3D

, otherwise you’re looking at the wrong curve.

MSI Afterburner or GPU-Z are good measurement applications too.

Hi Nathan, thank you for your answer.
Yes, you were right. Even though “cuda” actually showed around 10%, GPU-z showed a GPU load of 70-100% during V-ray RTX rendering.
I also noticed that my V-ray settings were way off from being optimal.
I was able to render a medium sized project at 4k, max quality settings in 3 minutes with a fair amount of light ray bounces. I don’t have any references but it shouldn’t be too bad.

So one of the two of the problems is solved, thank you!

My other problem is during the viewport of very large files. In the video I hope you can see my settings and my problem:

As you can see in the video, i tried messing around with the option with no success.

While importing this project i also noticed that the whole project is considered as 1 block. This was done on pCon planner and then imported to Rhino. That might be the problem i guess.

What do you think? I have not actually tried to make a big project from scratch in Rhino yet. If you have a sample I could try if the viewport is actually better.

I don’t know if this helps, but i run _PolygonCount:
There are 1.860.934 quadrilateral polygons and 25.160.705 triangular polygons in this selection
There would be 28.882.573 total triangular polygons in this selection after forced triangulation

Thank you

CUDA is used in the viewport in Rhino 6 and later only when using Raytraced when you have in Tools > Options > Cycles the render device set to a CUDA device.

In your video you’re only really showing GPU activity for 3D drawing in the left hand, you see not much is happening there.

I don’t know pCon, but if all is coming in as one big block then it isn’t going to be very efficient. Your model looks like many trees for instance could be handled with instances of one, likewise the lights, and so on.

If you want me to have a look at the file you can share it confidentially with me through https://rhino3d.com/upload?to=nathan@mcneel.com - I’ll get automatically notifed when the upload is completed.

I have a similar question. How can I make Rhino use 100% of my GPU instead of only 10% to increase FPS.