R6 scale bug?

unhandled

#1

Trying to scale the curve in this file. I use the scale command, select a corner as a base point, type in a scale factor and the curve moves rather than scales. Same behavior for the poly. Scale1D and 2D seem to work fine.
KIOSK.3dm (87.8 KB)


#2

Hmm, seems to work OK here on both the curve and the polysurface… Tried Scale with various factors from a number of different corner points, they always stayed “anchored”…

–Mitch


#3

Well, that’s bad. Now can someone tell me what’s going on with the edge display at the base? Same file with more modeling.
KIOSK.3dm (149.7 KB)


(Pascal Golay) #4

Hi Dennis - on that one the polysurface is ‘horked’. Did you use a sub-object selection on that top edge or something to scale the edge? I’d extract (ExtractSrf) those ends, delete and Cap to clean up.

-Pascal


#5

Yes I did make changes using solid points. This doesn’t happen on the same object in Rhino5.


(Pascal Golay) #6

Hm - so far that works here in V6 on a similar object…

-Pascal


#7

So what do I do? This is the first serious (money-making) project I’ve done in 6 and have found 3 bugs in the first 1/2 hour. I had to revert to 5 just to finish. This is bad.


#8

So this morning, I worked in the same file and scale worked correctly. The display of the isolines in the right view in wireframe were also correct. Any thoughts?