R6 render question

In the viewport under render option (below shaded) I can change the color of background but don’t know how to change the color of the object.
The default color is too white for me.
And how to save both?

Do you mean under Rhino Options > View > Display Modes > Rendered?

You can either assign a material to a layer in the layer manager or to individual objects in the properties manager:

I am not sure what you mean by that. If you set the background color in the display mode, that should be saved between sessions. If you assign materials to layers, you can save an empty file with custom layers and use that as your start-up template.

Thank you wim.
Sorry, I don’t how to attach the picture.

As a new user here, you don’t have rights to post attachments yet. Just read a few posts worth 10 minutes and you’ll be able to drag and drop files or use the upload button:

Thanks again.
What I need is to change background color and the object’s color perhaps similar to R5 and have it as default.

@mydanster, can you please copy&paste the contents of the Help > System Information... in Rhino?

Rhino 6 SR0 2017-11-14 (Rhino WIP, 6.0.17318.8561, Git hash:master @ d5a07f941ad16bc8f7c4006efb6db93c687d1f52)

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)

Intel® HD Graphics (OpenGL ver:4.0.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build
Driver Date: 10-8-2015
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2112 MB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

Ah, sorry. I thought you had your bg swatch set to black, but the bg showing up redish. I clearly need a pair of spectacles, I am getting old :confused:

Anyway, I think @wim gave you some instructions you can use to change object colors. Set the default layer to have a material (i.e. plaster with a grey color). Then save that file as a template.

… and use one of these two methods to set your background color:

  • In your template file: go to Document Settings > Render and change your backdrop color. Save as template. For this to work reliably, the global option in the display mode must be as factory-default.

  • As a global Rhino option: go to Options > View > Display Modes > Rendered mode and set the background to a color.

@nathanletwory, maybe a bit unfortunate that the same setting is called “backdrop” in one place and “background” in another?

I suppose so, reported RH-42600

Thanks everyone.