Quad remesh misses edge on open mesh


Don’t know if this question has come up earlier and if so please direct me.

When I try to quad remesh a mesh it misses some parts of the outer geometry.
I have tried so many settings without a solid result that I always can count on in order to have a “copy” of the original mesh perimeters.

In part below there is a miss on the lower right corner.

qremesh.gh (24.5 KB)

What am I doing wrong???
Thanks in advance!

1 Like

I think the mesh settings are simply not tight enough.

Disconnect the simple mesh settings. Then right click and set these mesh settings:

1 Like

Hi Scott and thanks for the reply,

That didn’t work eighter I’m afraid.
The simple mesh shows correct perimeters, it’s just the quad-mesh that gives wrong result.

I was thinking that using the boundary curve as a guide curve might help.

I can look a bit closer

Please do, I don’t know what I do wrong

I looked at you file and tested many things and didn’t manage to get a good tessellation ton the chamfered part. I think without fixing or magical setting the best you could do is finish the meshing by hand (mouse) dragging points on the corners.

1 Like

If you quadremesh using the rhino command does it turn out better?

1 Like

Hi Laurient,

This will be in a automation with many many hundreds of meshes, so I can’t be checking everyone of them unfortunately.

Hi Scott,

No I get the same result in Rhino as well.

OK so Mc Neel has to look at this glitch has it seems it is hard or impossible to get the good match with various settings.

What result do you expect on this corner?

I couldn’t look at your file yet…

Are all your objects planar?

1 Like

My expectation is that the whole original mesh should be filled as a quad except for tolerance issues.
On my file I get around 7mm difference which is way of tolerance so there must be something I’m doing wrong.

No I have both planar, curved and double curved objects

1 Like

What happens if you double the target face count?

1 Like

earlier today that’s what I was thinking related to ‘corner’, but I did drop the ball on this, and I’m not sure of the GH side of this cool stuff.

I’m interested to learn anything that develops. :beers:

I think a nice number like 2000 or so would be good, but definitely would use 100% adaptive size too. Plus interpolation and maybe creases…

Not much,

Even testing 10000 gives similar result.

qremesh_1000.gh (34.4 KB)

1 Like

Hi @martinsiegrist
I think there is still a slight problem in this corner (in V7 and V8!). The error is 3 units for an edge length of 20 and the error on the rounded part is 10 time better (~0.3). I see this as a glitch or bug.

It seems that this part is not detected as a corner, because when using this command in Rhino, it is rounded there and not on others corners

Yes but using the brep as input it is not as bad as the user reported.

I wonder why the result is better with the brep instead of the mesh?

Maybe the Quad Remesh algorithm would benefit of a ‘pull closest vertex to corner’ option… Of course something which could be done in Grasshopper quite quickly too

1 Like

If you hover on the input there is that !
It seems there is a mesh autoconversion
like the one if you connect to a mesh component

1 Like


Are we agreeing that I’m not stupid?.. (in this question at least) :slight_smile:
I hope to get some information from the guys at McNeel also in order to get some feedback.

1 Like