Quad Remesh fail with sucessful preview

I have a very dense mesh object that I need to make into a subd for processing.
(Rendered model preivew)

I’m trying to use quad-remesh to make the subD. I am able to successfully preview the geometry in the quad-remesh panel and everything looks good. But when I click ok, nothing happens. When I try quad-remesh without a preview, I get told that it failed. See the pictures bellow as reference. What is going on here?

Original mesh close up

quad remesh preview

1 Like

I was going to say ‘dont use preview’ and should work…

I’ve seen this bug. I think there’s other threads on it.

I couldn’t find any other thread which is why I started this one. Did any of those threads give an answer? Do you know an answer (since don’t use preview hasn’t worked)?

1 Like

Can you post the file?

1 Like

Have you tried to uncheck the “Convert to Subd” to obtain only the mesh?
It’s better to try to make one step at a time if the command fails somehow (probably the mesh that you see in the preview isn’t good and the ToSubd process goes wrong).
If the first step doesn’t work, I would try to increase the “target edge lenght” to something around “10” to see if the command works; if the answer is yes I would decrease the value until I find the smallest working one.

1 Like

I’ve tried finding it several times without any luck. I know it’s in here somewhere :face_with_monocle: :thinking: :thought_balloon:

I’ll let you know if I find it. I’m not sure if there was a solution. It might have been slightly different subject. But I think you definitely found a bug in the preview, cause I’ve seen it too. I think I’ve seen it both in the V7 and V8 wip. I don’t think I’ve tested the V8 release much in this regard.

1 Like

I can’t post the file as it is very large (over 500mb).

I just tried this and It made a mesh. The mesh then happily became a subD. Why won’t it work as a single command? What mechanism would cause such a failure? I would think that this command would simply perform the mesh, then generate the subd as two steps and output and final subd, making it functionally identical to making a mesh then making a subd.

1 Like

Probably that Rhino does not allow to add meshes to the doc which have errors / are invalid.



wouldn’t that mean it would fail even in the just mesh generation since the mesh is bad in the first place?

1 Like

@Trav, maybe it can be cured it you set requireValidMesh=False for AddMesh ?


1 Like

@cameronbehning, i can only guess as i have not written that code. Maybe the conduit which displays the preview mesh does not complain about the mesh beeing faulty.


1 Like

I’m still trying to find the one I was thinking of but here’s a slightly diff one for now:

Still digging. Found this gem from April lol:

It might have been the coffee talking haha.

So, I recommend to not use the preview or delete options in that dialogue, and simply try it multiple times again and again to see if it finally works. :wink:

And maybe upload a file so some of us can mess with the geometry too :smiley:

Hi -

You can use Rhino - Upload to Support to upload that file. Make sure to copy the url to this thread in the comments field.

Probably because computers and software are made by humans?
The bigger is the amount of data you are processing and the bigger will be the probability that something will go wrong… splitting the process in little steps is only a good way to get the work done and to understand where are the problems.

To produce a robust command the developer has to verify every tipe of situation that could happen.
Merging two commands toghether complicates the things in a way that not always someone can expect…
If you can upload the file to McNeel they will look at it, find the problem and, if it is possible, teach the command how to fix it.
That’s the only way to help developers to give us a good program.