Qt platform error while importing

Hi,

recently i’m having this issue when i try to import, insert or open an obj or fbx:

202202 6_1952

i can open, insert and import 3dm files without problems. any idea?

System info:

Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17001)
License type: Comercial, build 2022-01-10
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 64Gb)

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 3.3

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version: 30.0.15.1165
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Thanks!

Hi -

Please post the complete system info.

Apart from that,

What made you turn the OpenGL level down a notch? From the looks of it, your GPU should be able to use the best level…
-wim

1 Like

Hi

full system info:
Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17001, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Comercial, build 2022-01-10
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 3.3

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version: 30.0.15.1165
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Doliwa Workshop\Rhino Nature\Rhino Nature.rhp “Rhino Nature” 1.0.1.18266
C:\Users\Usuario\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\TeDAsharp (ce983e9d-72de-4a79-8832-7c374e6e26de)\0.1.0.0\TeDaSharp_050.rhp “TeDAsharp” 0.1.0.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Users\Usuario\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ColorPicker\6.0.0\ColorPicker.rhp “ColorPicker”
C:\Users\Usuario\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.0\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.1.0.0
C:\Users\Usuario\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Usuario\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

About OpenGL level, never touched it, i left it as installed

Thanks!!

I think VRay uses Qt. Try disabling VRay and see if that makes a difference

Thanks Steve! You’re right: if i disable Vray there are no more issues with obj or fbx files.
Any idea how to solve this?

Thanks again

Hi -

Make sure that you are running the latest version of V-Ray. If that doesn’t help, you’ll need to contact ChaosGroup to resolve this issue.
-wim

hi -

i’m running the latest one:
V-Ray 5 for Rhino, update 2.3 (Official release)
Release date
Jan 28, 2022

I’ll contact Chaosgroup

Thanks

Hi -
About this one…

I’d put the slider completely to the right (i.e. “Max OpenGL Available”) on the Rhino Options -> View -> OpenGL page.
-wim

1 Like

This is a missing windows.dll in the platforms folder of a qt application.
You have a plugin developed with qt and the startup is wrong or dll is missing

Gd

It was Chitubox software, Chitubox is using a global handler with the same version of Qt as V-Ray is using

Thanks!