Python incompatibility in 2015-02-18 release

When I launch the 2015-02-18 release, I get the following pop-up window.

(I have the start up automatically on launch).
(The script is posted in this thread: )

Side note: the bug with the Command List under Rhino Options > General getting populated with double entries is still there…

I’ve changed the title in this thread from “AutoCPlane in 2015-02-18 release”.

When I tried to run a short script (from this post) in this WIP release, I also got the Exception Occured error with Message: ‘module’ object has no attribute ‘GetString’.

Seems like RH5 python scripts are having problems in this release of the WIP.

Hi Wim,

The “module object has no attribute…” or “no module named…” kind of messages come from the fact that python can’t find the library. This may be a local problem on your end - here I just downloaded the latest version and scripts are working.

In the script editor, do the paths to the libraries exist and are they correct?

C:\Program Files\Rhino WIP\Plug-ins\IronPython\Lib

C:\Users\<user>\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib


Thanks for a quick reply, Mitch!
What you say makes sense and I’ll have to check on my RH6 PC later today.

The thing is, I’ve run the AutoCPlane script at startup for a long time now without problems - it’s just with the latest update that this is no longer working. So in that case the WIP installer messed something up with its paths. You are not having out-of-the-box problems with the latest WIP?

OK, testing further, I am not having problems with most scripts, but I did find one set of stuff that is not working - anything that involves using an open or save file dialog (via rs.OpenFileName or SaveFileName) :

‘OpenFileDialog’ object has no attribute ‘ShowDialog’
‘SaveFileDialog’ object has no attribute ‘ShowDialog’

I have not tested other stuff extensively, the scripts you mentioned above seem to work…


I can now confirm that those directories are both set in the script editor under tools > options and that those directories exist.

OK, odd that the symptoms on your end are not exactly the same as those on my end… @stevebaer Something is definitely messed up though… --Mitch

Yeah, and I just installed the latest on another laptop (Win8 as opposed to Win7) and when I start that, Rhino crashes right away. I’ll go into safe mode to delete the automatic start-up of this script…

Just checked my home machine and it’s showing the same error “…no attribute ShowDialog()…” --Mitch

Sit back and relax until the bigger brains get a chance to look this way. :slight_smile:

This is still an issue in today’s release.
@dale or @stevebaer, is this on the radar?

Hi Wim -

Yep, I know, this is a pain.

See if removing the script clears that start up error…? V6 now has

testAutoCPlaneView, which may make the script redundant anyway.


Thanks Pascal!
:wink: I know how to get rid of the start-up error but I’ve been keeping it there as a reminder of functionality that I would like to continue to be there.

That sounds good!

I guess it’s all in the “may” :grin:
I’ll have to check it when I get a chance but that sounds like it behaves like the latest version of that script and not an earlier prototype that - to me - was the right way of implementing that functionality.

I made changes to RhinoCommon and forgot to update the rhinoscriptsyntax functions. Thanks for pointing this out. I made a bug track issue for this at

1 Like