Projecting/Pulling curves onto a semi-spherical polysurface

Hi, does anyone have a solution for this…

I am trying to pull a set of curves in a hexagon pattern onto a polysurface. Each time, I end up with this: (it doesn’t reach the sides).

I also tried projecting but this only projected on
to the top and not the sides:

My geometry for context:

Any advice?

Hello - pull sucks the curves in along the surface normals - the normals on the lower ‘sides’ do not ever hit the curves . FlowAlongSrf with the right setup will be better, I would say. Your targets are revolved surfaces so the base surface for the flow should be a revolved line, not a rectangular plane.


Okay, thank you Pascal. I am new to rhino so would you offer how to do this revolved line please?

Hello- here’s an example - see if that is along the lines of what you are looking for - because the target (black) is a revolved surface with U and V arranged around a pole, I made the base surface (green) also ‘polar’ by revolving a line - the blue grid is mapped to the domey thing using FlowAlongSrf

FlowToSingularityExample.3dm (119.0 KB)


Sorry again, I am still confused.

Hello- try it - delete the flowed blue grid and select the flat one, start FlowAlongSurface and then click on the outer edge of the green surface as the base surface and the black one as the target surface. Does that do anything like what you want?


1 Like

Not all hexagons (a few pentagons in the mix) but the new TriRemesh component in the Mesh section of Grasshopper in Rhino 7 may be of interest as an alternate workflow here.


Hi Pascal; I tried on your model file and it works so I understand now, thank you!..but replicating it on mine…it won’t let me select what is selected yellow as the base surface.

Hi Brian,

Thank you for this! I used Weaverbird on grasshopper but it wouldn’t allow the ‘vertical’ wall-like part of the dome which is what I needed. From the image you have shared, it seems like ‘TriRemesh’ allows for that hexagon pattern vertically before dome-ing.

Could you offer any tips/directions please?

It’s seriously fun, just try it. You can feed in anything and the Dual output of the TriRemesh component will have that mostly hexagonal pattern. I like to throw a mesh edges component at the end to see the edge size controlled by the length input. That’s what you could bake out if you just want the curves. For added excitement, feed those edges into the new MultiPipe component to make a SubD. This is all thanks to @DanielPiker by the way.

1 Like

[Solved; It was because I had a polysurface rather than 4 surfaces…extracting surfaces to create the 4 quarters, selecting each quarter as multiple breps] Thank you, this is what shows when I use the same Grasshopper components as your image…it doesn’t follow the geometry - see the break at the top:

Hi @jh1546 - can you share the file with your Brep internalised? I’d like to see what’s going on here.

@DanielPiker I would but my file crashed and I didn’t save it! But I remember what I did so here are the steps I took to solve that:

I had the geometry in rhino as a closed polysurface. This as well as selecting that polysurface when setting “one brep” caused the distortion at the top of the geometry. To fix this, in Rhino I Extracted Surfaces from the closed polysurface (my geometry), grouped those 4 surfaces together and in Grasshopper “set multiple breps” selecting each of the 4 quarters (surfaces). This fixed the output.

Hope my steps help. Again, sorry about not having the file!

Thanks - as long as you have something working now it’s all good!
I can’t think of a reason why the brep was causing problems unless maybe there was also a duplicated surface in there somewhere. There normally shouldn’t be any need to split Breps into separate surfaces.

1 Like

HI @DanielPiker , for some reason my 4 quarters which are each a surface do not align with each other regarding the hexagons/pentagons. Any advice?

Can you post the file?
It looks like you have multiple surfaces being remeshed separately.
You need to input them joined into a single Brep, and turn the Sharp setting to False to avoid creating feature curves along the seams.

1 Like

@DanielPiker ah ok. Here I have posted the files. Thanks for this!

Parasite rhino 7 model.3dm (4.9 MB)
hex rhino 7 (8.9 KB)

It looks like when joined into a single brep, the initial Rhino mesh created from that geometry before remeshing has some naked edges, even where the Brep doesn’t.
Here are a couple of different ways to resolve this - remaking the surface as a single revolve, or keeping it as a brep and aligning the vertices: (8.5 KB) (50.1 KB)


Thank you so much!

1 Like

Hi @DanielPiker , I wonder if yourself or someone else may suggest a way to make the multipipe square rather than circular?

This is my set up/ files with it circular (highlighted green)