Project won't turn off


#1

every time I click in the window it turns back on.


#2

correction. I turn it off I make a box (or a line or whatever) and then it turns back on.


(Pascal Golay) #3

HI Aaron, I’ve seen this as well a couple of times lately and I cannot reproduce it reliably so far - my guess is it has to do with the settings file - try: Options > Advanced > type Project in the search box and manually set

Rhino.Options.ModelAid.ProjectSnapTo ClippingPlane to False.

Aha - Note the error in the setting name - that might be a clue as to why it’s going haywire sometimes…
https://mcneel.myjetbrains.com/youtrack/issue/RH-37242
-Pascal


(John Brock) #4

I can’t make it act as you describe here.
I can turn it on and off in a command or not in a command.

Try this:
Draw a circle in the Top viewport.
Select it and drag it up in the Front view.
Turn on Project
Start the Line command and in the perspective view with the Center osnap turned on, float your pointer over the circle.
The line should project to the Cplane.
Turn off Project and float your pointer on on the circle again.
It should not project to the cplane.


#5

no its the osnap keeps turning itself back on… pascal I’ll try your tip.


#6

Thanks, it worked!