Cant turn off Grid Snap?


#1

Hi Everyone,

Im new to posting on here, but have been a user of Rhino for a few years, Im hoping this is in the right section.

The issue I’m having is with the grid snap automatically turning on in Rhino 5. I’ve tried this on two different machines, one works perfectly for a few hours then all the sudden the Grid Snap function automatically turns on, even when the toggle on the bottom menu is off. It does this until I restart the machine, then eventually will do it again. The other machine always does this regardless.

I took a screen capture of what its doing, Im trying to snap to the bottom of the pill shaped curve, and its trying to snap to the grid even though the toggle is off. Is there another setting that I’m missing somewhere, or is this some kind of bug? It also only seems to happen in the perspective view.

Thanks,
Josh


(Vanessa Steeg) #2

Hi Josh,

The problem is not the Grid Snap, it’s that you have “Project” activated. “Project” will project the object snaps onto the cplane. Maybe you activate it by accident when checking/unchecking osnaps?

Cheers,

  • vane

#3

Thanks Vane! That was it. I must be accidentally turning that on and off at points.