Everything that involves osnap, is projected elsewhere, and not in the correct lacation

Hi, as a title
here is a video example with the polyline: https://mega.nz/#!yyx3gIYI!I4I2mTiiAhen6YEigR-QFTCvpEppn9TOo4vBdlKXW-w

uncheck “Project” in your Osnap toolbar. With it checked, snaps are projected to current CPlane.