Problems splitting surface

So i am trying to split this surface and nothing seems to work. Split, Trim or Wirecut all failed. Any suggestions?

Can you post the file with the surface and the trimming object? Pretty much impossible to know why from the image… --Mitch

Thanks for checking it out. trim.3dm (4.3 MB)

Wow… that is weird… You can split the surface with the curve, but it splits into… 380 pieces! :dizzy_face:

Also intersection or pull create 47 curves… Never seen that one before. The surface seems OK…

No idea offhand what’s happening there for the moment… @pascal any clues?


Nope , none so far… I’ll hand it over to the bigger brains… I’m off in the classroom this week…


The surface is folded on itself.

Display surface control points and try selecting one. Most, but not all, are actually two control points which are almost but not quite coincident.

DupBorder, and use the border curve to Split the surface. Four surfaces result which overlap with each other, and at least one of those four surfaces is folded on itself.

@acpavel Was this surface imported or did you create it? If so how did you create it?

Wow! Thats what Blend Surface gave me when i used it on this mesh in order to fill the gap. The mesh is in the scene but i’ve hidden it.

@acpavel When you say “mesh” do you mean what Rhino calls a “surface”?

Can you upload the surfaces you used as input for BlendSrf?

Polysurface. Sry i’m used to he houdini terminology. If you type the show command, it does’t show up? It was in the scene but hidden when i uploaded it. I will upload the file again when i get home in 1 hr

Here it is: trim.3dm (4.3 MB)

How did you use BlendSrf between parts of a single surface? Of did you use some other command or method?

I used BlendSrf on both sides. I clicked on one side and then on the opposite side and it worked…or so i thought…

It looks like using BlendSrf to blend from an edge to itself caused the folded surface.

Two alternatives:

a) Split the first suface in two (using the Isocurve option works well), and then BlendSrf the two split surfaces.

b) SplitEdge the edge to be blended, and then BlendSrf between the split edges. You can use MergeEdge to put the edge back together if needed for subsequent operations.

The resulting blend surface using either method should behave properly.

Not only is the surface folded in on itself as david suggested, it’s sort of like a deflated balloon, but also adjacent control points have ended up on the opposite sides of the surface. If you split the surface with dupedge you will need to extend the resulting curve a bit to get the split to work, then you’ll see the mess of surfaces.

Probably better to re-model - one way is to contour and loft etc, then the split will work. The contour curves will need to be rebuilt before the loft, as they cut through the mess of surfaces. I stopped short of the ends with the loft just to demonstrate a possible solution.

@BrianM - Are you discussing the blend surface, or the first surface which was used to create the blend?surface.

I used to DupBorder, not DupEdge, to create the curve for splitting the original blend surface, and did not need to extend anything,

My recommendation to @acpavel is to build a new blend surface using one of the two methods I provided in my previous post.

Hi David, I was looking at the surface problem from the first post, looking for suggestions, no, not the blend.

Thanks! Only alternative b worked.

Thank you al! I did manage to blend the surfaces after all. It still needs some work as the blend is too obvious.
It’s for the shape from this thread: Advice on how to create this shape

Here’s my blend: