Problems running rhino 6 on a new PC

Hello everyone,
Im Tal and im a architecture student for some time now.
Recently i bought a new PC to run Rhino and more relevent programs,
I got the Asus Rogstrix. i was told this PC will be enough to run Rhino and i saw many friend who is doing fine with the same PC.
for some reason when i turn Rhino on, even without any project in it the GPU cant take it.
The work becomes slow and i cant work on the same project as my friends.

is there any setting i need to change so the rhino will be any more “light” on my PC, getting desprate.
thank you for the help.

Most common is old drivers. Posting your _Systeminfo here often helps

Im sorry but what info do you need? the GPU is Nvidia geforce GTX 1060 GDDR5 6 GB as the picture say.
i will check nvidia web if there is an update on the drivers. thank you.

Type the command _SystemInfo in Rhino and copy that info here will give support the info they need

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Evaluation, build 2019-12-17
License details: Stand-Alone
Expires on: 2020-03-26

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-PG2O7KJ

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Users\talca\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 0.0.19316.1331
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

other than a driver update there isnt anything that I know to help you. Just curious though, looking at your screenshot cpu at 85 and gpu at 89 seems a bit too much

Some people complain about it but GEForceExperience mantains my drivers automatically up to date without much hassle, I even use it for the Quadro card I got at work.

Your drivers look okay.

I suspect it’s the Enscape plug-in.
As a test:

  1. Run the Rhino Options command
  2. Go into Plug-ins, and change the filter at the top of the list to Plug-ins that do not ship with Rhino.
  3. Disable them.
  4. Close and restart Rhino.
    Is the performance better?
  5. If it is, go back into the plug-ins page and enable them again.
  6. Close and restart again.
    Does the slowness come back?

My Rhino runs well on that same card.

If a machine runs hot even without much load you need to check all air intakes and filters, fans and heatsinks on all parts (CPU, RAM, GPU, PSU). Clean them out thoroughly.

Further make sure your Windows is up to date.

Ensure there are no bloatware running. I am one of those who doesn’t install GeForce Experience. Check the task manager for high CPU usage processes (in case you have “received” software that does bitcoin mining or other CPU intensive tasks you didn’t sign up for).