Problem with Vray Matte shadow receiver inside interior

I need to make an animation of a piece of furniture that’s moving inside an otherwise static interior.

To prevent me from having to render hundreds of images, in which 75% is the same static interior on each frame, I’d like to render the static backdrop only once, and render the moving furniture separately and use the alpha channel to paste as an animation on top of the backdrop.

For this to work well, I do need to have cast + occluded shadows that the moving furniture generates on the floor below it, as well as the reflected colors of the surrounding interior that affect the color of the moving furniture piece.

To simplify things, I’ve just placed some wall surfaces with basic color shaders (no textures, no details) around the moving furniture and made the those shaders invisible so as not to show up in the alpha channel. (rememeber, I want to use the backdrop image. These walls are just here to affect the furniture color) So far so good…

The problem is with the cast + occluded shadows:
The Matte Shadow Receiver works well placed beneath geometry in exterior environments (think of a car to be placed onto an image with a road)

But when I use the Matte Shadow Receiver below my moving piece of furniture inside the interior, then the MSR doesn’t just produce the furniture’s shadows, but also receives reflected light from the surrounding walls.

See the below image to show you the different outputs for exterior and interior environment with MSR.

Anyone have any solutions to set up VRAY in such a way that MSR only prrovides the data to the alpha channel to add some white to the black of the alpha’s mask where the cast+ occluded shadows sit below and beside the furniture piece? (as it does in an open exterior space when there’s no interference from surrounding walls)

Thanks a bunch!

Hi, how did you make the walls invisible?

It’s done on the level of the shader, not the geometry.

On the shader (material), click on “add attribute” which sits just below the material preview window.
Then, under “raytrace properties” you can uncheck “visible to camera”

1 Like