Need shadow catcher advice

unhandled

#1

Can someone look at this screen shot and tell me what I’m doing wrong?

I have a circular disc under my objects and the material (grey floor) is applied to it. I then select grey floor in the base material slot of the wrapper material, check matte and shadows. But my grey floor doesn’t become transparent and I have no shadows.

Thanks in advance for your advice.


#2

There is a material in the library called Matte Shadow Receiver normally just use that:

.

The other thing to check for is a visible dome light. The wrapper material doesn’t support matte with a visible dome light.


#3

Thanks for the reply.

Fortunately I have Thea which handles things like this in a very direct way - call up Rhino’s ground plane, apply Thea’s shadow catcher to it, done.

So I switched to Matte_Shadow_Receiver and deleted the dome light but still no success. I seem to get better shadows but no way to increase or decrease them. And no transparency on floor.

Any other thoughts about what I might do?

Also, does your email imply that V-Ray can’t have both a shadow catcher and an hdri at the same time? Whenever possible I light with only a hdri.

Thanks for your input.


#4

@arail you attach the HDRI to the background environment and you can still use an invisible dome light.


#5

Thanks but no luck. Shadow Catcher is applied to the disc below my geometry, no transparency. Dome Light is disabled.
Honestly, I think the Environment, Background panel is a confusing mess.

This is the setup:

And this is what I can get with 3 clicks in Thea. No light set up, no multipliers, just 3 clicks:

I don’t understand why it’s so difficult and confusing in V-Ray 3


#6

I learned something after posting this - V-Ray seems to be sensitive to the history of a scene. What I mean is, I finished the scene and rendered it out in Thea (see above). Then I copied the geometry, dragged it to a new location, turned off the ground plane and swapped out the Thea materials for V-Ray materials. No shadow catcher.

Then I selected the geometry (that had V-Ray materials applied) and copied it into a fresh scene and the shadow catcher worked. Not sure why that would be but there it is.