Problem with: smooth on mesh object

rhino5
mesh

#1

Hi there

I’m trying to replicate a “smooth on mesh object” youtube tutorial and cannot make it work. When I click smooth mesh, it doesnt smooth it at all, instead it does an awkward joint between corners.

Here is the tutorial I’m using : https://www.youtube.com/watch?v=j4DPO5aNnto

Am I doing anything wrong? Help appreciated :blush:


(Pascal Golay) #2

Hi Paula - use Weld on the mesh first, at 180 degrees, then Smooth. Does that sort it out?

-Pascal


#3

hi Pascal,

Thanks so much for the quick response. Unfortunately I’ve tried what you have just suggested me and this is what I get:

I’ve welded the mesh at 180, if I just weld the corners it gives me a better result but still doesn’t allow me to give it a decent softness level.

Any thought? Thanks so much again


(Pascal Golay) #4

Hi Paula - see if RebuildMeshNormals does anything good to the result. Post the file if not…

-Pascal


#5

Pascal
I’m afraid Rebuild mesh normals doesnt seem to work. Could u please have a look at my file? I’d appreciate it so much :slight_smile:smooth object.3dm (381.6 KB)

Paula


(Pascal Golay) #6

Hi Paula - starting with the mesh in the center:
Switch to wireframe view
The mesh has two pieces - SplitDisjointMesh or Check will show you… you can see that the mesh vertices do not match up between the two pieces. So, as one mesh, use MatchMeshEdge see how the edges are cleaned up and triangulated.
Now, Smooth.

Better?

-Pascal


#7

Sorry Pascal, I don’t understand what you mean by the mesh vertices dont matched up. Regardles, I’ve tried to splitdisjointmesh and it has shown me 1 complex volume mesh + a surface mesh. Is that what u mean with the mesth has 2 pieces? Sorry I’m being such a pain… :frowning:


(Pascal Golay) #8

Yeah- to Rhino, those are just meshes. But, look, in wireframe, at where the two meshes ‘connect’ - see how the vertices do not match?

Smoothing will move those apart:

`MatchMeshEdge’ helps get all vertices on the two pieces lined up so each vertex has a matching one on the other piece - the image is of the mesh still as one mesh, not split out:

Now Smoothing keeps things together:

-Pascal


#9

Thanks so much for all the effort with explanatory sketches. I do get now what you mean. This is, however, what I get if I match the mesh and smooth.

This file is doing my head in :disappointed_relieved:

Pascal, would it be possible if u upload back the file I’ve uploaded with the object fixed according to ur criteria?

Thanks so much


(Pascal Golay) #10

Hi Paula - uncheck the setting in Smooth for ‘Fix boundries’. Also, many small smooths is better than one large one - set to say, .1 or .05 and then just hold the Enter key until it looks right.

@paula_viejo - here’s what I get - is that more or less what you need? (MatchMeshEdge, Weld, Smooth)

smooth object_PG.3dm (277.9 KB)

-Pascal


#11

Pascal, If if uncheck fix boundries…:sweat:


#12

Yayyyyy it worked!!! Thanks so much you have just made my day Pascal :heart_eyes: