Problem with ShapeDiver import geometry

I have upgrade ShapeDiver to version 1.12.2 and tried to used Import geometry component but it doesn’t work on my account. I have Pro Account and use Rhino7.

After uploading definition If I chose import geometry “uvezena” in dropdown “Kriva1” menu, I have only screen with logo.

In another example, scene with new import geometry component delete mesh that is affected by default dwg. file connected: ShapeDiver This is the same grasshopper definition but with old import geometry component: ShapeDiver

Legacy Pro accounts are linked to Rhino 6 servers. Did you try to open your definition in Rhino 6 and make sure it works there?

I sent request to connect my ProAccount to Rhino7 system and received information that my request was accepted on 5th october 2021. Request was sent to Ezequiel Lopez.

I didn’t use Rhino6 anymore (Rhino 7 is released in december 2020). I have old ShapeDiver License (version 1.9) on old Rhino6.

I just tried old grasshopper definition on Rhino6. Geometry input component works now. But does it mean that If I am Pro user that I have to use old ShapeDiver and Rhino6 ???

Pro accounts are not part of the plans ShapeDiver offers anymore. All existing features will keep working forever but in order to use more recent premium features, one must switch to one of the new plans.

Note that the latest version of the plugin is also available for Rhino 6, so (almost) all features of ShapeDiver are available there. You can install it using the package manager (if you have a manually installed version, make sure to remove all existing files before).

Thanks for answer. I tried to install latest ShapeDiver to Rhino 6 from food4rhino website, but I have problem. Everytime when I click install button for Rhino6 version, I receive following message: Open Rhino 7?

Please start Rhino 6 and use the TestPackageManager command.

Thanks, it works!

Many thanks for reporting this problem. We will fix this in the upcoming release, most probably it will be published next week. Is it correct that this error pop up does not block the plugin from working for you?

@Bojan_T I just realized you added this message to a completely unrelated thread. Please delete it and start a new one.