Problem with rendering using vray

I have a problem with rendering in vray. The file is about 540 MB which is not THAT much as far as im aware but my computer might not be suitable for it, i have pretty good specs so i thought it wouldnt be a problem. When i try to render it with vray, the program just turns off. Its stops at compiling geometry or building light cache and doesnt even start to create any image. I did Audit3dmfile and it seems like theres a lot of objects (around 8k so maybe thats the problem?). I tried managing meshes a bit or creating blocks but the file size doesnt change or keeps bloating so im not sure whats wrong. I would really use some help cause i need a few renders for tomorrow and im running out of ideas.

Hi @Klara

The 3dm file size has nothing to do with the scene complexity. A very simple scene can lead to excessive render time. It is all about the light, and how it bounces around.

Since the renderer apparently stops at compiling geometry or building light cache it is rather an exception of some sort.
It would be great if you could share the model file somehow - PM me with a link to the .3dm or a .vrscene or contact Chaos Support.
Alternatively you could:

  • make sure you’re using the latest version of V-Ray
  • make sure you’re rendering on the CPU, so GPU memory is not an obstacle
  • check the number of lights, and try to reduce them if possible
  • check whether you have non-native objects - like RPCs or some other plugin’ objects. Check if hiding them will work
  • use the Material Override option and use a simple color for all materials

If none of the above works, try to hide ~50% of the geometry and render again. If it still doesn’t work, try hiding ~50% of the rest and render again.

The general strategy is to try to simplify the scene to a point where it renders, and thus identify what is causing the problem.
If the scene complexity is not the issue, you may have problem with the installation of V-Ray itself.

Okay, thank you, i will try these suggestions and will update

i deleted displacement maps and it seems to be working, the render looks pretty flat tho but its fine for what i need so
im almost sure that the issue might have been something else and i could render w those but im glad i solved it somehow

You could still share the model with me privately, so I can debug the application, though
as you wish