Problem with license checking on our network

During the beta we worked out the settings so Rhino would be able to check the license through our (finnicky) network.
It relies on storing the user’s network credentials to be able to contact McNeel’s servers. The problem is that we have to change our password every few weeks and I don’t see how to update this in Rhino. It fails with a few error messages and no visible way to enter new values.
I can’t ask for the update to v6 in our company if this is not improved.

Hi @Marc,

it fails with a few error messages

Would it be possible for you to send me a screenshot of one or more of these messages?


Hi Andrés,

Let’s start with this one:

And I have to mention that v6 is taking way too much time with all this checking. My users can’t be this patient evry time they open a new session or open a new file.

Understood. If I remember correctly, your company uses a proxy server to connect to the internet, is that correct?

Yes, that’s right

So, before you get this message, you don’t have a chance to re-authenticate?

No it did not… until just now!

So, what did trigger this dialog?
Can we invoke it in some way when it’s needed?

@aj1 I wonder if there’s a problem in our code that doesn’t try to get you to re-authenticate until the lease is completely expired?

Do you mean that Rhino is unresponsive before showing the dialog? Or that the dialog comes up so often that it’s annoying? Or something else?

Well, it takes a long time before the dialog shows up. And then it does it’s checking and that feels very long too. And then it fails and I know why it fails (I know before I start Rhino because it’s me who changed the network password) but there’s nothing I can do about it.

Thanks for those details. We’re pretty new to this whole authenticated proxy thing.

As a total hack of a workaround, you could delete the proxy file that Rhino saves. I think it’s in %appdata%\mcneel\rhinoceros\6.0\license manager\licenses\ and it’s next to cloudzoo.txt.

And I agree that Rhino should be much faster at noticing that the proxy isn’t configured correctly and offering to have you reconfigure it.

@Brian Higher level code, such as licensing calls have no say in a network request.

@Marc, Brian’s hack should work for the time being but the file should be in %appdata%\mcneel\, not in %appdata%\mcneel\rhinoceros\6.0\license manager\licenses\

At any rate, I’ve created a bug item that you can follow to investigate and fix this problem.

The file “proxy.txt” is in %appdata%\mcneel\rhinoceros\6.0\
If I delete it and start Rhino, the window “Contacting McNeel servers” shows up for around 8 seconds and then disappears and Rhino resumes loading. No questions about proxy settings.

Can I really follow this bug item? I’m not allowed to view it with the username I tried.

Correct. The item view is currently open only to “Developers”.
I’ll check with AJ. It’s pretty “wonky”.

1 Like

Sorry about that Marc. There are three places in the system to set public view. I had missed one. You should be able to see it now.

Thanks Andrés.
It seems there’s no way to set up a notification when there’s work done on an issue?

@Marc I’m not sure how notifications work on our bug tracker, but for me, if I click on the star next to the title, it sends me a notification every time the item is changed.

Oooh, the star! Even the tooltip doesn’t give a clue…


@aj1 could you notify me here if you want me to do something, do some testing or else.