Problem with divide domain / creating ArchiCad element from loft component

Hi there,

I am quite new to grasshopper.
I was wondering how to transfer a loft created in GH into an ArchiCad element (e.g. a shell).

It worked well with the first loft:

But I have trouble with the more complex lofts and don’t know what to do:

I hope somebody can help me with this issue.
Thanks a lot!

Anke (13.5 KB)

You didn’t internalize your curves.

Thanks siemen for your quick reply.
I clicked on internalise data for both curves but it doesn’t make a difference. Is there something else I have to do?

Save the GH file after internalize? Do them one at a time? ‘Internalize data’ is not broken. Keep trying. Open your GH file without opening your Rhino file to make sure it works.

Thanks Joseph for trying to help out. I did all the things you said but it still doesn’t work with the loft component.
(How come the first loft works without internalising the curves?)
I tried the ruled surface component and now it seems to work (without internalising) :slight_smile:

The only point of internalizing the curves is so that the rest of us can see your geometry. It will have no effect on Loft. But until you internalize your curves and re-post your GH file, we are helpless. Your ‘Curve’ params cannot be orange if you want us to see them:


Ah now, I got it. Sorry about that!
Yep of course, here is the file with the internalized curves: (15.2 KB)

UsingJoin Curves and Loft with Refit option… (9.7 KB)

Oh that’s awesome! Exactly what I needed. Thank you so much! :slight_smile: